4

I've programmed an Adafruit Feather nRF52840 board to send MIDI signals to my computer via BLE. I can confirm that the board pairs successfully with an Android phone and a Windows PC, but my laptop (MacBook Pro 2021) will not recognize the board; it does not appear in the Bluetooth menu as an option for pairing. I've tried the following troubleshooting options:

  1. Turned bluetooth off & on on laptop
  2. Turned device off & on
  3. Added the name of the board in the code (advertisement.complete_name = "BOARD_NAME")
  4. Downloaded Bluefruit Buddy, Bluefruit Connect & Bluetility to find any BLE signals coming from the board (verdict: no trace!)
  5. Tried a BLE smart dongle
  6. Unpaired/forgot device from Android phone, attempt to re-pair with laptop
  7. Attempted to connect the device via Apple’s Audio MIDI setup (https://support.apple.com/guide/audio-midi-setup/set-up-midi-devices-ams875bae1e0/mac)
  8. Tried steps 1-7 with two additional MacBooks (2016 & 2022)

I know that the BLE pairing functionality of the board is working, since it consistently pairs with an Android phone and a PC laptop; I just cannot figure out why it won't pair with my MacBook. I want to resolve this issue and ensure that the board can be used across platforms.

Are there any other troubleshooting actions I should try?

5
  • try pairing with a Windows PC and a Linux PC
    – jsotola
    Jun 11, 2023 at 19:23
  • 1
    this is not a question about the Arduino until you determine why a Mac does not accept the connection
    – jsotola
    Jun 11, 2023 at 20:42
  • @jsotola, I tried pairing with a Windows PC yesterday and the board showed up in the Bluetooth menu and paired successfully. This is a good sign, however I still need the bird to work across all platforms. I posted the question in this forum to see if possibly there was any hardware setting on the board that may impact its ability to pair with a Mac (i.e. double-tapping the reset button or holding down for a certain amount of time). Generally, I just wanted to know if anyone else had run into this issue or could suggest helpful ways to troubleshoot beyond what I’ve already done.
    – carsoap
    Jun 17, 2023 at 18:51
  • What macOS version do you have?
    – Fahad
    Jun 18, 2023 at 11:02
  • Ventura for two computers, Catalina for the 2016 MacBook
    – carsoap
    Jun 19, 2023 at 12:54

1 Answer 1

0

Have you tried Bluefruit Connect from Adafruit? It is available in the Apple store. Don't quote me on this, but I read a long time ago, that Mac requires encryption for a BLE device to be recognized, whereas, most of the out-of-the-box Adafruit example doesn't use it.

I had a similar issue. And I used Bluefruit Connect to connect my device to my Mac.

enter image description here

5
  • Item not available in my country? Got a download link to the app not involving the "app store"? What versions of OSX are supported?
    – VE7JRO
    Jun 12, 2023 at 2:11
  • Unfortunately, I can't seem to find the information about what OSXs are supported on the app page, but I have "macOS 10.14".
    – Fahad
    Jun 12, 2023 at 2:22
  • Too bad it's not available in other countries besides the US.
    – VE7JRO
    Jun 12, 2023 at 2:27
  • That's unfortunate. Also, I found what OS are supported: "Requires macOS 12.0 or later and a Mac with Apple M1 chip or later."
    – Fahad
    Jun 12, 2023 at 2:29
  • Yes, I have tried Bluefruit Connect, Bluefruit Buddy & Bluetility. None of these apps are able to detect the board.
    – carsoap
    Jun 12, 2023 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.