1

It will be simple. I started to look at the sketch of the Arduino Robot and just tried one, Disco_Bot, and uploaded it one the top board. The Arduino started to play some music and the name was on de LCD screen but he wasn't moving. Then i tried then sketch Wheel_Calibration. The information was on the screen but the Robot was supposed to move so that i could calibrate the speed. I was lost so I went on the Arduino page for the Arduino Robot (http://arduino.cc/en/Guide/Robot) and found nothing that could explain my problem . So now I ask you, can you please help me because iI have no idea on what i should do.

Chris

  • Doesn't it require batteries for the motors? I tried looking at the schematic, but couldn't find the motor driver, so that was of no use. – Gerben Mar 14 '15 at 21:04
  • 2
    Did you unplug the USB cables from the robot? The robot will never move if connected to some external device; this is a protection measure. – jfpoilpret Mar 15 '15 at 7:55
  • Did it work before (motors board) or it never worked since you have it? Is it possible you unintentionally uploaded something on the motor board and overwrote the sketch there (which you are not supposed to do except if you really know what you do)? – jfpoilpret Mar 15 '15 at 9:00
  • @Greben, well normally it comes whit a set of 4 pills but i noticed that the motor doesn't use the batteries and i have power it by a other source. Thank you for you're help ! – Christian Théron Mar 15 '15 at 13:32
  • @jfpoilpret, in the back i got i sed that it was all tested before shipping, but is thing i also did plug the usb cable on the motor board and may have overwrote the sketch that was preloaded. I'll try to find them to reste the board. Thank you for you're help ! – Christian Théron Mar 15 '15 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.