1

I'm using Version: 2.0.3 - Date: 2022-12-05T09:30:25.33 on Windows 10 Pro. Installed under Local user - not for all users.

When I try and open a ino file (either double clicking on a ino file - or file->Open) - it spawns a new window - but then I just see the standard sketch with an empty setup() and loop()

I've uninstalled and re-installed both for my own users and all. But still, it does the same thing. I'm having to open all my sketches in notepad++ and then save them in whatever temp Arduino file it creates. Its hellishly annoying

6
  • 2.0.3 may be broken ... try another version
    – jsotola
    Commented Feb 20, 2023 at 12:39
  • Hmm. happening on 2.0.2 too
    – willwade
    Commented Feb 20, 2023 at 16:08
  • And if you run it as "Administrator" ?
    – MatsK
    Commented Feb 20, 2023 at 17:12
  • 1
    Thanks @MatsK - I think its a bug due to my dodgy filesystem on windows.. I see this in the output 2023-02-21T11:22:21.224Z sketches-service WARN Warning! The request sketch path was different than the response sketch path from the CLI. This could be a potential bug. Request: <\\ace-svr02\Users$\wwade\Documents\GitHub\X80\firmware\x80Tester\x80Tester.ino>, response: <\\ace-svr02\Users$\wwade\Documents\GitHub\X80\firmware\x80Tester>.
    – willwade
    Commented Feb 21, 2023 at 11:24
  • 1
    If you try to open a sketch from a shared drive on Windows, it does not work. See the bug here. When opening a sketch fails, IDE returns to a new temp sketch. That's why you see void setup(){} void loop(){}.
    – dankeboy36
    Commented Feb 24, 2023 at 15:25

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.