Updated picture

I'm creating a telemetry package for my my mom's model rocket with a MPU6050, a BME280, and a SD reader/writer. The code I found for the BME does not read any information. When I upload an I2C scanner, the MPU gives a signal, but the I2C gives "No i2c signal found". The wiring schematics are the same. I've tried different boards, and I've tried different code. Nothing works.

  • 1
    Sorry I did not clarify. The code I was using was the 12C scanner code. Feb 18 at 15:59
  • 2
    Your image does not show VCC and GND connected to your BME280. If that's not your actual wiring, show your actual wiring.
    – timemage
    Feb 18 at 17:24
  • 1
    Is it a 3.3V or a 5V module?
    – DrG
    Feb 18 at 18:05
  • 3
    the picture shows no power connection and no ground connection ... you are trying to fly a rocket without an engine
    – jsotola
    Feb 18 at 19:00
  • 1
    You mean that it's reversed left-to-right and that in actual use it's the CSB and SDO that are unconnected? Really you should just get a picture of it as wired so as not to confuse the crap out people.
    – timemage
    Feb 18 at 20:56

1 Answer 1


@ModelRocketeer - I appreciate your frustration and I hope this will be of some help.

First of all, you have to make sure the board is wired correctly and it is anyone's guess whether it is wired correctly because you have not shown that to us and that frustrates us because we would like to help.

Here is a very similar board attached to a D1 mini. enter image description here

If I flip it over to show the signal names, AND line it up correctly, one can see how it is hooked up....or it is just confusing because it is flipped over. enter image description here

  • BUT why not just tell us, like this:
D1 mini<->280
3.3v   <-> Vcc 
GND    <-> GND
D1     <-> SCL
D2     <-> SDA

AND show us a clear picture because many eyes on it can increase the likelihood of solving the problem.

BTW: using colored leads helps with checking.

I have several of these generic 280 boards - they are cheap and when I bought mine, they were sold as BME280, but it turns out (after hours of frustration) that they were in fact BMP280. Apparently, the board can hold either. Be forewarned.

I tested my board with a D1, like yours at 3.3v, and an UNO at 5.0V and they both worked.

I then tested a known-to-be BME280 and it worked fine with the D1 mini.

In ALL cases, I was able to use a port scanner and see the I2C address (0x76).

Because you have not been able to detect any connection over I2C for the board but can detect a port for the MPU6050, I think you need to do the following:

Make sure you have the proper connections.

Remove the MPU6050 and have only the BMP/BME connected and run the scanner.

If you still see nothing, I would say the board is bricked. Because you said you tested several boards, I suspect (as have others) that you do not have it connected properly.

When you get it connected properly and can see a port when scanning - try running BME software but if you use the Adafruit programs you might need to force I2C since this is not an Adafruit board. The latter is able to use both I2C and SPI.

If you still don't get results, consider that it may, in fact be a BMP280 and try software for that.

In either event, please let us know what happens.

  • Did you wait until I finished responding to get it to work? :)
    – DrG
    Feb 18 at 22:00
  • Feels like it, but I stepped away from it for a few hours, and when I came back to it I redid everything and it "worked" though the pressure value, the only one I need is giving me an absurd value and saying I'm 32,000 feet in the air. Feb 18 at 22:06
  • Yes, it can't do exact altitude on its own - see arduino.stackexchange.com/questions/44715/…
    – DrG
    Feb 18 at 22:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.