2

I have two UNO boards from a few years ago. They look the same as far as chip placement goes.

I can plug both in and get flashing lights on them, and when I hit the reset (2x the on-off) button, they both make the same LED "noises". Since the LEDs on the non-detected board flash the same start-up sequence as a board that is detected, I assume both boards are working.

One of them has "UNO" printed on the circuit board and the other has "GCRduino Rev 1.0" printed on the circuit board. (edited according the comments for clarification)

I'm using Linux Mint 21 and Arduino IDE 2.0.3.

On hardinfo (the linux program), both of them are listed in Devices->USB Devices as "QinHeng Electronics CH340 serial converter."

The one that has UNO printed on the board is detected and I can load software onto it. The one that say GCRduino is not detected by the IDE and no new entry shows up in /dev.

The GCRduino is detected for a split second and then disappears again. check this video: http://100wires.com/arduino.mp4

9
  • Welcome to SE/Arduino! Please take the tour to learn how these SE sites work. -- Are you sure that the GCRduino has a compatible boot loader? Please edit your question and tell us what your research on the device has revealed so far. Jan 2, 2023 at 11:03
  • Arduino clones that use the CH34x chips generally do not show list the IDE or hardware lists as being a particular board, because the necessary information to positively identify them is not provided by the CH34x chip. So, I'm skeptical that "one says UNO is detected" and "both of them are listed as...CH340...". are both true. Make sure the information in your question is correct.
    – timemage
    Jan 2, 2023 at 12:59
  • @timemage Presumably "says UNO" means that the word "UNO" is printed somewhere on its circuit board. ;-) Therefore I don't think the OP wanted to say that Linux reports "UNO". Technical terms are difficult for casual users. Jan 2, 2023 at 13:11
  • Yeah, I'm stumbling on the grammar I guess. Anyway, I take your point.
    – timemage
    Jan 2, 2023 at 13:29
  • i've updated the post for accuracy.
    – iateadonut
    Jan 2, 2023 at 13:35

1 Answer 1

1

I found the problem with dmesg. When I insert the card and it shows up very briefly, it gets kicked by another device:

[  167.032321] input: BRLTTY 6.4 Linux Screen Driver Keyboard as /devices/virtual/input/input25
[  172.660038] usb 3-3: new full-speed USB device number 9 using xhci_hcd
[  172.809032] usb 3-3: New USB device found, idVendor=1a86, idProduct=7523, bcdDevice= 2.62
[  172.809038] usb 3-3: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[  172.809041] usb 3-3: Product: USB2.0-Serial
[  172.810938] ch341 3-3:1.0: ch341-uart converter detected
[  172.811372] usb 3-3: ch341-uart converter now attached to ttyUSB0
[  173.349731] input: BRLTTY 6.4 Linux Screen Driver Keyboard as /devices/virtual/input/input26
[  173.655257] usb 3-3: usbfs: interface 0 claimed by ch341 while 'brltty' sets config #1
[  173.656203] ch341-uart ttyUSB0: ch341-uart converter now disconnected from ttyUSB0
[  173.656275] ch341 3-3:1.0: device disconnected

I can see the device on lsusb:

Bus 003 Device 008: ID 1a86:7523 QinHeng Electronics CH340 serial converter

That same device serial number is listed in

grep 1a86 /usr/lib/udev/rules.d/85-brltty.rules
ENV{PRODUCT}=="1a86/7523/*", ENV{BRLTTY_BRAILLE_DRIVER}="bm", GOTO="brltty_usb_run"

So when it connects, it gets kicked off by it being detected as another device.

So I just comment out that line in /usr/lib/udev/rules.d/85-brltty.rules, restart, and the board can now be detected.

2
  • Seems to be the same as this issue.
    – timemage
    Jan 2, 2023 at 15:20
  • 1
    It is, thanks. I've updated my question with more keywords/descriptions so maybe other's can more easily find the problem.
    – iateadonut
    Jan 3, 2023 at 1:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.