-2

I have an issue with my Arduino pro mini. Yesterday, I uploaded a sketch a few times on the pro mini, with an FTDI adapter, and everything worked fine. Today I'm trying to re-upload a sketch, but now, for some obscure reasons, my Arduino pro mini doesn't want to reset itself. I need to manually reset it. Since it is embedded in s case, I can't do that if I want to upload a sketch.

EDIT: I managed to make some tests, and it would seem that the DTR pin on the mini doesn't work anymore. When I short the DTR PIN to GND, the mini doesn't reset itself. I believe that could be a reason. But why? And how? It was working a day ago.

I soldered the FTDI like that, and it didn't work several times. (At the moment I left it unsoldered because I don't want to solder it yet):

setup

Can anyone complete my intuition?

Thanks in advance.

10
  • Did you solder it? Or did you use a "female" connector soldered? Please edit your question and add this information, optimally with an actual picture of your assembly. Commented Dec 18, 2022 at 13:44
  • I edited the question, the connection is soldered, but it doesn't work
    – BruceWawe
    Commented Dec 18, 2022 at 15:20
  • You have nothing else connected to the board besides the FTDI adapter? You have selected the "Arduino Pro or Pro Mini" from the standard AVR based Arduino support and not something else (e.g. minicore)?
    – timemage
    Commented Dec 18, 2022 at 19:01
  • No, I have only my FTDI, and I selected "Arduino Pro or Pro Mini" from the standard AVR based Arduino.
    – BruceWawe
    Commented Dec 19, 2022 at 11:10
  • "When I short the DTR PIN to GND, the mini doesn't reset itself" if you are doing that with the FTDI adapter still soldered you are either trying doing what the FTDI adapter is already doing (which is of no use) or you are trying to short out DTR by connecting it to ground while FTDI is trying to drive it high (not really a good idea either).
    – timemage
    Commented Dec 19, 2022 at 14:50

2 Answers 2

0

Is this is an actual photo of your FTDI and mini? I can't tell whether the FTDI pins are soldered to the mini. If not, I would guess that the problem is an unreliable electrical connection at one of the pins, and look there for the problem.

If it helps, this is what I use for my embedded devices. The FTDI is in the USB-A connector. The embedded end is just a female connector that pushes onto the 6 pins on the board. This cable supplies +5v; there are also ones that supply 3.3v.

FTDI Cable

Thanks for your answer, the connection is soldered.

In that case, I'd check the resistance of the solder joints including trying to wiggle them; then trying to narrow it down by swapping FTDI boards if you have another; and likewise, swapping the mini board.

1
  • Thanks for your answer, the connection is soldered. I don't think it's a connection problem, I verified the soldered connection, tried to bend them, there's nothing to do. Thanks for you picture, it seems I have the same connections. Really don't know where to look ...
    – BruceWawe
    Commented Dec 18, 2022 at 15:21
0

The reset pulse issued by the USB-Serial adapter via the DTR line may be of low amplitude (3.3V). This is occasionally too low for the Pro Mini reset function. Sometimes, it helps to solder a 47k resistor across the reset button contacts, lowering the initial DC level of the reset input. This applies to 5V/16MHz and 3.3V/8MHz versions of the Pro Mini.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.