1

I bought a ESP8266 module (like this). I connected the module like on the following scheme: scheme

I use a USB to TTL converter (cp2102) that I've connected to RX&TX pins of the module. It works. It successfully transmits data in both ways when I test it with a MCU. I often use it to send debug messages to my PC from a MCU.

I use linux and CuteCom as a program for monitoring the data sent through the serial port.

I supply 3.3V to the module (as required by the manufacturer) from the cp2102 converter (it has both 5V and 3.3V outputs).

The problem

The module does not respond to any command I send to it (AT, AT+GMR, AT+RST, ATE0, etc). But it sends to the PC some data on boot (when I attach Vcc to CP_PD). Most of the data look like garbage, but at the very end I get meaningful data:

Ai-Thinker Technology Co.,Ltd.

invalid

The baud rate is 115200. No parity, 8-bit characters, 1 stop bit. The full output from CuteCom: data

The red LED on the module is always lightning while the power is supplied. During the boot process (approximately first 500 milliseconds) also a blue LED blinks a few times (probably due to sending that mostly-garbage data to the PC I mentioned earlier).

What have I tried?

I experimented with the resistor R1, tried: no resistor, 1k, 3k, 10k. I also tried other baud rates (1200, 2400, 4800, 9600, 19200, 38400, 57600). And tried using all the parity types, 2 stop bits and other character lengths. Nothing helped.

Why the module does not respond to any command? Hope for your help! Thanks in advance!

1 Answer 1

2

The ESP8266 bootloader outputs messages at that 74880 bits per second. At other speeds the bootloader's messages will look like garbage. Set your terminal speed to 74880 to see them.

On the ESP8266 it can be helpful to also use 74880 bits per second for the Serial speed in your program so that you can easily see both your programs output and the boot loader information when your program crashes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.