2

I tried to upload example code form arduino software and got error below. Two arduino attach with my computer running windows8.1. And These arduino using port 3 and port 4. The arduino using Port 3 is cordinator and arduino using port 4 is router. I doesn't understand why error show COM1 is not available. I am not using COM1.

Arduino: 1.6.0 (Windows 8), Board: "Arduino Uno"

Sketch uses 1,030 bytes (3%) of program storage space. Maximum is 32,256 bytes.

Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.

C:\Program Files (x86)\Arduino/hardware/tools/avr/bin/avrdude -CC:\Program Files (x86)\Arduino/hardware/tools/avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM1 -b115200 -D -Uflash:w:C:\Users\Jiya\AppData\Local\Temp\build1135139715306090793.tmp/Blink.cpp.hex:i 


avrdude: Version 6.0.1, compiled on Apr  3 2014 at 23:12:16
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino/hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : COM1
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: ser_open(): can't open device "\\.\COM1": The system cannot find the file specified.


avrdude done.  Thank you.

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

Board at COM1 is not available
Board at COM1 is not available
Board at COM1 is not available
Board at COM1 is not available
Board at COM1 is not available

  This report would have more information with
  "Show verbose output during compilation"
  enabled in File > Preferences.
4

(I'm assuming you're using the official Arduino IDE here.)

Before uploading a sketch, you need to select which port you want to upload to. Within the Arduino IDE, click on the Tools menu and open the Port submenu. Click on the port your Arduino is connected to, such as COM3 or COM4.

You also need to ensure the appropriate board type is selected in Tools -> Board.

You should then be able to and upload the sketch.

0

Did you try with code bender. In my experience, uploading through the code bender works all the time even if it fails with Arduino IDE

0

On windows systems, COM1 is usually the system port, so you shouldn't use that for programming.

Try updating device drivers by going to device manager and right click on the COM3 and COM4 icons for the arduino boards.

If this keeps persisting then try reinstalling the ide and restarting your computer

0

Experience has taught me twice... to make sure you use the right cables. I used a spare cable that ended up being a power brick charging cable, i.e. no data lines. Make sure you use a decent USB cable - preferably one that asks you question on a cellphone when connected to a PC, so you know all the internal wires are there and working.

-1

your kernel need to provide support to USB ACM.

CONFIG_USB_ACM=y

you can look for it at:

$ zcat /proc/config.gz | grep CONFIG_USB_ACM
CONFIG_USB_ACM=y
-1

If all the other solutions don't work and you are on a Linux distro try sudo arduino and that should work, or follow these instructions: Getting Started With Arduino on Linux (Ubuntu)

  • 1
    It looks like the user is on a Windows machine – and on *nix even the super user can't open a nonexistent file :-) – dlu Jan 3 '16 at 3:20

protected by Juraj Dec 6 '18 at 8:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.