3

I just purchased an Adafruit Wifi Shield CC3300 and strapped it onto my Arduino Uno board.

I'm running this basic sketch that I found to test the functionality of the Wifi Shield: http://arduino.cc/en/Guide/ArduinoWiFiShield#toc1

Of course in my home I have Wifi, so I expected this sketch to show my Wifi name. However it doesn't. Instead I get this output on my serial monitor:

Init...
** Scan Networks **
Initializing Wifi...
MAC: 0:0:0:0:0:0
Scanning available networks...
** Scan Networks **
number of available networks:0
Scanning available networks...
** Scan Networks **
number of available networks:0

It just keeps going forever detecting zero networks. I even took the Arduino and stood 3 feet away from my Wifi router. Still nothing. I even tried making my cell phone a Wifi hotspot and holding it right next to the Arduino. Still nothing. And why does it say the MAC Address 0:0:0:0:0:0?

Can anyone suggest a fix? FYI, here is a photo of what my setup looks like:

enter image description here

  • 2
    Do you know if the Adafruit wifi board is compatible with the Arduino wifi shield libraries? Adafruit provides their own libraries on their tutorial page here: learn.adafruit.com/… I would try using their code with their hardware first. – krol Mar 6 '15 at 16:37
  • Also what's up with the headers floating, are they even soldered to your WiFi shield? – Avamander Aug 29 '15 at 8:55
  • Was this ever solved? I'm having the same issue with an Arduino Uno and the Wifi/SD Shield. – Matthew Johnson Jan 3 '17 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.