1

I checked several answers for same question but none of them help.

I also changed the nano board and GPS module but without luck. I ran it outdoor.

This post question had same issue except my date does not display the correct date and time.

My connection:

vcc->5V
rxd->d4  
txd->d3  
gnd->gnd  

FullExample program from TinyGPS++, I get following types of entries

Sats HDOP  Latitude   Longitude   Fix  Date       Time     Date Alt    Course Speed Card  Distance Course Card  Chars Sentences Checksum
           (deg)      (deg)       Age                      Age  (m)    --- from GPS ----  ---- to London  ----  RX    RX        Fail
----------------------------------------------------------------------------------------------------------------------------------------
0    100.0  ********** *********** **** 00/00/2000 00:00:00 152  ****** ****** ***** ***   ******** ****** ***   324   0         0        
0    100.0  ********** *********** **** 00/00/2000 00:00:00 230  ****** ****** ***** ***   ******** ****** ***   486   0         0        
0    100.0  ********** *********** **** 00/00/2000 00:00:00 308  ****** ****** ***** ***   ******** ****** ***   648   0         0        
0    100.0  ********** *********** **** 00/00/2000 00:00:00 384  ****** ****** ***** ***   ******** ****** ***   810   0         0        
0    100.0  ********** *********** **** 00/00/2000 00:00:00 463  ****** ****** ***** ***   ******** ****** ***   972   0         0        
0    100.0  ********** *********** **** 00/00/2000 00:00:00 541  ****** ****** ***** ***   ******** ****** ***   1134  0         0  

NMEA read from serial

$GPGGA,,,,,,0,00,99.99,,,,,,*48
$GPGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*30
$GPGSV,1,1,01,05,,,20*7F
$GPGLL,,,,,,V,N*64
$GPRMC,,V,,,,,,,,,,N*53
$GPVTG,,,,,,,,,N*30

$GPGGA,,,,,,0,00,99.99,,,,,,*48
$GPGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*30
$GPGSV,1,1,01,14,,,29*76
$GPGLL,,,,,,V,N*64
$GPRMC,,V,,,,,,,,,,N*53
$GPVTG,,,,,,,,,N*30

UPDATE:

I change the antenna. At some time I got this. From the GPGSV sentence I know that there are about 15 16 satellites in view but the FullExample only show 0.

$GPRMC,,V,,,,,,,,,,N*53
$GPVTG,,,,,,,,,N*30
$GPGGA,,,,,,0,00,99.99,,,,,,*48
$GPGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*30
$GPGSV,4,1,15,04,,,31,07,,,33,09,,,34,11,,,30*74
$GPGSV,4,2,15,12,,,33,13,,,30,14,,,33,15,,,27*7D
$GPGSV,4,3,15,16,,,33,19,,,34,20,,,30,21,,,33*70
$GPGSV,4,4,15,22,,,32,23,,,33,33,,,35*7B
$GPGLL,,,,,,V,N*64

$GPRMC,,V,,,,,,,,,,N*53
$GPVTG,,,,,,,,,N*30
$GPGGA,,,,,,0,00,99.99,,,,,,*48
$GPGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*30
$GPGSV,4,1,16,04,,,32,07,,,33,08,,,31,09,,,33*7A
$GPGSV,4,2,16,11,,,29,12,,,33,13,,,30,14,,,34*73
$GPGSV,4,3,16,15,,,32,16,,,33,19,,,33,20,,,31*73
$GPGSV,4,4,16,21,,,33,22,,,33,23,,,34,33,,,35*7D
$GPGLL,,,,,,V,N*64

My idea now is to supply external power for the DFRduino Nano

Any idea how I can continue. Should I changed to other type of gps module?

8
  • "I ran it outdoor" Under a clear sky and for some number of minutes, right?
    – timemage
    Aug 19 at 16:13
  • @timemage yes. From this post, it takes 1 or 2 hours to charge EEPROM and the onboard RTC. Without RTC syc time, it cannot get correct date time in my case Aug 20 at 6:07
  • You just have made some interpretation with with my name. I wasn't asking about time/RTC output at all. Only that you had it where we could be certain that you would get a fix at the end of so many minutes if everything were correct. So many avoid this. With your update it seems whatever software is involved is correct so far as it goes. Check your antenna connections, that nothing (including the Arduino) near is injecting interference, and try powering it from different sources.
    – timemage
    Aug 20 at 17:39
  • @timemage With 5V power supply from Nano I got the module damaged (Rx Tx get shorten), do you have any idea? Aug 21 at 7:16
  • A short has nothing to do with the problem here. Besides that shortening RX and TX doesn't damage anything (unless you connect two TX pins)
    – PMF
    Aug 21 at 11:49

1 Answer 1

2

The ceramic antenna is the issue. I changed to the external 1.5GHz one. It got fix under 5 seconds

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.