0

I'm having a sketch, that works perfectly fine - connects to WiFi, uploading files using Esp32 LittleFS data Upload using Arduino IDE (when still connected to my PC), and sketch updates via OTA (using ArduinoOTA.h library).

But when I try to Esp32 LittleFS data Upload when MCU is not connected to my PC, I get an error messages:

espota : /home/guy/snap/arduino/70/.arduino15/packages/esp32/hardware/esp32/1.0.6/tools/espota.py

[LITTLEFS] data   : /home/guy/Documents/Dropbox/Arduino/sketch_jul26a/data
[LITTLEFS] start  : 2686976
[LITTLEFS] size   : 1472
[LITTLEFS] page   : 256
[LITTLEFS] block  : 4096
/sketch_param.json
/sketch_param_32.json
/myIOT2_topics.json
/myIOT_param.json
/sketch_param_8266.json
[LITTLEFS] upload : /tmp/arduino_build_103180/sketch_jul26a.littlefs.bin
[LITTLEFS] IP     : 192.168.2.132

Sending invitation to 192.168.2.132 ..........
20:10:59 [ERROR]: No response from the ESP
LITTLEFS Upload failed!

Just to clarify:

A) sketch OTA works as expected (yes, I changed local USB to the remote one).

B) Tested on 2 different ESP32 MCU's, and failure is the same.

Question:

  1. Is it possible to OTA data files using ESP32, ArduinoOTA.h, LittleFS, ArduinoIDE ? (It works when using ESP8266).

Guy

0

1 Answer 1

1

I can confirm that I've uploaded littlefs data to an ESP32 over OTA using PlatformIO. I haven't tried with ArduinoIDE but it should be possible. Have you tried uploading while monitoring the serial output (i.e. leave it connected to the PC). If you see something in the output, it might be format error coming from the ArduinoIDE upload tool, but I suspect it's just failing to connect.

Is it definitely connecting with the same IP between sketch upload and file upload? When I have these types of problems, it's usually because I've done something in the sketch to disable WiFi or the OTA check. Have you tried uploading the sketch again over OTA?

1
  • Uploading sketch, as mentioned, works flawlessly. And entire procedure on ESP8266 works both sketch and data files (sketch fits both MCUs).
    – guyd
    Commented Aug 16, 2022 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.