2

I installed arduino 1.8.19 (64-bit) on a Fedora Linux 35 Workstation Edition system. When I started the IDE, and selected the "Open" menu icon, the menu item list appeared, but there was no text displayed with the items. I could open sub-menu items, but there was still no text. It looked like:

The "Open" menu with no text

I tried several other 1.8.x versions, but with the same result. I haven't found any discussion about this on the Web. so I suspect that it is problem with my configuration. Nevertheless, any suggestions will be most welcome. I have not tried to install the IDE on Windows 10, but that is an option.

6
  • wow, that is frustrating ... what is your specific question?
    – jsotola
    Jun 23, 2022 at 22:57
  • You may want to run it from a terminal and check the output there for clues that you may then want to add to the question.
    – timemage
    Jun 24, 2022 at 4:39
  • My specific question is, "What can I do to be able to see the menu items?" I installed the IDE on Windows 10 and it runs as expected.
    – Jim Marek
    Jun 24, 2022 at 4:51
  • Starting the IDE from the command line gives an error, but I don't what it implies nor how to eliminate it. Gtk-Message: 01:05:10.314: Failed to load module "pk-gtk-module"
    – Jim Marek
    Jun 24, 2022 at 6:07
  • 1
    Thanks, jsotola. So far a Google search has turned up 3 suggestions. Sadly, none of them have helped. 1. Install PackageKit-gtk3-module. dnf responds that it already is installed 2. Create a new gtk2.cnf that points to /usr/lib64/gtk-2.0/modules. Didn't resolve it. 3. Extract the missing library from a Fedora 16 system (in the archives) and move it to the "modules" directory. The 3rd suggestion resolved the missing library, but, alas, did not resolve this issue of no text being displayed. So I am still hoping for suggestions.
    – Jim Marek
    Jun 24, 2022 at 16:35

1 Answer 1

2

There is a incompatibility between Arduino 1.8.19 and Fedora 35. On another PC, where I was running an older version of Arduino, I upgraded to Fedora 36 and the upgrade warned me of the incompatibility with the older Arduino and Fedora 36 and said it was deleting Arduino. After the Fedora upgrade completed, I installed Arduino 1.8.19 and it worked as expected. When I upgraded the original PC, the one with the no text in the menus, to Fedora 36, the menus also worked as expected. Hallelujah!! So, all is well and I have my answer. Thanks for your replies.

Arduino 1.8.19 and Fedora 36 are working as expected

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.