-1

I have purchased a couple of different types of DigiSpark Attiny85 clones (couldn't find originals available) and they have worked great except some devices (so far, just laptops) don't see the device AT ALL.

It's not that they don't recognise it and so is a driver issue - there is nothing to apply the driver to, no indication that the thing is even plugged in other than the light comes on (so I know it has power).

More frustratingly, if I plug the Digisparks in to any problematic device via a docking station, USB hub, etc. everything works as expected (confirming the drivers are ok) and I can write scripts to the digispark.

I've tried updating the Nucleous bootloader but the problem persists. I get this problem on three modern laptops (HP & 2 Dells) but my older Lenovo laptops have no problems. Not sure if here is an issue with modern USB controllers?

UPDATE: Everything points towards it just being an issue with Digispark's and some USB 3.0 controllers. The clock is correctly set at 16.5Mhz so not sure what else to do other than write these-off as a reliable device.

Anyone had any experience of this or have any suggestions?

Thanks!

5
  • 1
    It might be the bit-banging implementation of the USB protocol via the built-in oscillator, I don't know, it's just a thought. Modern USB controllers might be picky on timing. Perhaps you can check and adjust the frequency of this oscillator. I have one of these "fake" clones (rev.3) and it works on a new and an old ThinkPad. Jun 17 at 5:51
  • @thebusybee, thanks for comment - from what I've read, there seems to be issues with timing specifically with some USB 3.0 controllers which is inline with what you've said and my observations (digistump.com/board/index.php?topic=1622.0). I'm not familiar with adjusting the frequency and haven't seen anything on this subject in the various posts about this issue so I suspect it might just be an inherent issue that isn't going away. I've tried updating micronucleous to the latest version too but no luck.
    – Mr Fett
    Jun 22 at 16:07
  • Not sure why I was down-voted but I've read the criteria and don't feel like it was warranted. Does anyone have any suggestions so I can avoid it in the future. Personally, I'll never down-vote with commenting why I've done so.
    – Mr Fett
    Jun 22 at 16:10
  • 1
    Well, I did not downvote, because you did some research and made your issue clear. Oh, BTW, you surely mean "without commenting why", don't you? -- Perhaps someone with a logic analyzer and some USB decoder and a similar setup can shed some light on the problem. Many years ago I needed 2 weeks to find protective diodes with too large capacitance this way. -- Or, if you happen to use Linux, you could try to track the system's messages while plugging in. Or you use Wireshark and its USB driver to check at a very low level. -- Anyway, I cannot help further right now, sorry. Jun 22 at 18:11
  • @thebusybee, yep you're right - I missed the "out" out If you know what I mean!). Really appreciate the help - I'm going to give up on these boards as they are just too hit and miss!
    – Mr Fett
    Jun 23 at 16:39

1 Answer 1

0

It appears the problem is down to issues around Attiny85 timing with USB 3.0 chipsets and so isn't something that can be solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.