I am using SIM800L module the module. I am new to GSM modules, so I've searched for the basic to use the GSM with the Arduino. this is my code.

#include <SoftwareSerial.h>

SoftwareSerial mySerial(2, 3); // RX, TX

void setup() {
  // put your setup code here, to run once:

void loop() {
  if (mySerial.available()) {

  if (Serial.available()) {

when I send any AT commands to the GSM I didn't find any respond, so I changed the baud rate of mySrial and try different rates to get any respond, but I didn't get anything.

The wiring of the circuit is:

  • The 5V of the GSM connected to 5V of a power supply (the maximum current of it is 3A).
  • The GND of the GSM to the GND of the power supply.
  • TX of the GSM to pin 2 of the Arduino.
  • RX of the GSM to pin 3 of the Arduino.
  • GND to to GND of the Arduino.

The module has two LEDs:

  • the first one D6 NET blanking every second.
  • the second one D2 RING blanking every (7, 6, 8 or 9) times of the first one.
  • 1
    What line ending do you have selected in the serial monitor?
    – Majenko
    May 27 at 15:18
  • Both NL & CR and No line ending May 27 at 16:07
  • try switching RX and TX pins .... on a modem, TX usually means transmit on modem channel, so it should be connected to the Arduino TX pin ... the SIM800L module may have pins labeled same as a modem
    – jsotola
    May 27 at 18:10
  • In addition to the power supply connecting to the VCC and GND of the module, You need to connect the VDD pin on the module to your Arduino 5V (if you are using a 3.3V MCU, then connect it to 3.3V instead of 5V). This enable the level-shifter on the module for communication.
    – hcheung
    May 28 at 1:23
  • @hcheung I did it and connect the VDD to 5V of the Arduino but the problem didn't solve. May 28 at 12:10

1 Answer 1


You would have to check the wire connections, remember the wire are connected this way.


Tx pin -> Rx pin Rx pin -> Tx pin gnd -> gnd

if your are using SoftwareSerial library.

SoftwareSerial modem(rxdpin, txpin);

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.