-1

So I have an adafruit feather M0 LoRa 900 MHz and try to connect it to a helium hotspot (add to my helium console). For that I use the official helium documentation provided by helium and I get to the point of uploading the sketch to the board, but (as stated guide) if I open the serial monitor afterwards I only get an error message called: EV_JOIN_FAILED with a seemingly random number behind the error message. The output of the serial monitor looks like this:

22924969: EV_JOIN_FAILED

24125790: EV_JOIN_FAILED

25510651: EV_JOIN_FAILED

26731900: EV_JOIN_FAILED

28546725: EV_JOIN_FAILED

29506788: EV_JOIN_FAILED

30549623: EV_JOIN_FAILED

31955928: EV_JOIN_FAILED

33169043: EV_JOIN_FAILED

34528464: EV_JOIN_FAILED

36263160: EV_JOIN_FAILED

37424536: EV_JOIN_FAILED

38958548: EV_JOIN_FAILED

40127470: EV_JOIN_FAILED

40996827: EV_JOIN_FAILED


I made sure to edit the config file of LMIC and also triple checked that I entered the correct AppKey, Device EUI and App EUI into the test program.

My goal is to connect my adafruit feathe M0 to the helium console and send a Hello World packet and get developing.

Help would be apreciated.

Edit: Here is a screenshots of the adafruit feather M0 itselfadfruit M0

6
  • Can you please include the number behind the error message? Does it change or does it stay the same? Did you make sure to attach antennas and flip the jumper as stated in the guide?
    – Nick S.
    May 13 at 6:08
  • the number is always changing and I will include a an example of the output of the monitor in a minute. The antenna is properly installed and the jumper should be as well but I will include a photo of the board just in case.
    – Snake1507
    May 13 at 10:25
  • Okay, the number that you see is the "timestamp" of the device or the ticks number. Your setup looks right. Could you please include the serial monitor output right after you flash? It should at least tell you it tried to join the network. Also, you've unlinked the guide you used - now it just points to the image of the board.
    – Nick S.
    May 13 at 15:42
  • Okay, it´s good to know that the setup is right. I included the official helium documentation again, sorry for messing that up. The problem is that this is really the only output that the serial monitor displays. It doesn´t tell me that it tried to join the network or anything.
    – Snake1507
    May 16 at 6:08
  • It might be also worth mentioning that, since I´m in the EU, I tried to modify the lmic config.h file to, instead of using the #define CFG_us915 1 line, use the #define CFG_eu868 1 line. That just gives me the following error while compiling: 'LMIC_selectSubBand' was not declared in this scope; did you mean 'LMIC_setupBand'?
    – Snake1507
    May 16 at 8:48

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.