4

I have an Uno, and I can play all I want with it, just using a USB cable.

Then I got two Nano clones, and they both show the same behavior:

When I connect it to the USB cable (which leads to my PC) it blinks a few times, then seemingly does nothing. I am also not able to connect to it via the Arduino IDE.

If I then connect an external power source to Vin and Gnd, it wakes up and blinks forever, and I am able to connect to it.

Is this just because I got a cheap clone? Or is this really the accepted / expected behavior?

enter image description here

  • Should work. Place a say 100 Ohm resistor across USB power leads (about 50 mA load). What Voltage? Remove R :-) | What is USB input voltage to Nano loaded? What brand is clone? – Russell McMahon Feb 27 '15 at 23:35
6

I have a few clones but have not seen this behaviour so I guess it could be one of three things (in order of most likely to least):

  1. They have a fault related to taking power from the USB connector.
  2. The USB lead is not able to supply enough power ie. it is cheap and extremely thin and cannot carry much current. Have you already tried other cables?
  3. Your USB port cannot supply enough power. Given that the spec says 500mA from a USB 2 port, this seems unlikely unless the port is faulty. Have you tried other ports / another PC?
  • What is the reference of the board that you used ? – MAC Feb 27 '15 at 19:41
  • @MAC: Are you asking me? If so, sorry, but I don't understand the question. – Mads Skjern Feb 28 '15 at 7:32
  • @Crispy: Using another port made no difference. But using a different USB cable did. Crazy :) Thanks! – Mads Skjern Feb 28 '15 at 7:34
0

To answer your title question, My Nanos run at significantly less than the 500 mA you can draw from a normal USB port, so unless you have a cable problem it should be getting enough, yes.

One thing I have learned about cables is that your mileage may vary. For the Pi, it is nice enough to show me a lightning bolt on-screen when it isn't getting enough, and swapping the cable fixes it 99.9% of the time.

Arduinos simply display odd behavior like this one.

I always suspect power supply first.

So first, try changing cables. Then if that doesn't help try changing Arduinos and see if the problem follows the Arduino.

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.