1

It's important to start by saying that this micro was working perfectly, and the keyboard I built with it was great. Then this happened:

While using the QMK Toolbox I tried to upload an oversized .hex file, and since it was taking too long, I hit the reset button. Clearly uploading an oversized hex file was the problem here.

Now the pro micro won't respond to anything. The green LDE lights up, but windows won't recognize it. I tried clicking the reset button and grounding the reset pin, and nothing works. I even tried the double tap on the reset key, or the tap and hold, nothing.

Have I totally broken the micro somehow? Can't I hard-reset it?

7
  • 1
    Reinstall the bootloader...
    – Majenko
    Commented Feb 9, 2022 at 16:20
  • how @Majenko? I can't connect to it....
    – Deleteman
    Commented Feb 9, 2022 at 16:33
  • did you try a double reset? it activates the bootloader
    – Juraj
    Commented Feb 9, 2022 at 17:18
  • 1
    @Deleteman With another Arduino or hardware programmer (USBASP for example).
    – Majenko
    Commented Feb 9, 2022 at 18:31
  • 1
    Can I use another pro micro for this? @Majenko
    – Deleteman
    Commented Feb 9, 2022 at 19:37

1 Answer 1

2

Alright, just answering my own question in case someone comes along in the future:

The problem in my case, as @Majenko mentions in the comments, was the bootloader. In my case, there was no way around it, I had to re upload it with a ISP. I got another Arduino Pro Micro and using the wiring from this answer: Trying to verify that Arduino Pro Micro ISP is working and following this tutorial: https://docs.arduino.cc/built-in-examples/arduino-isp/ArduinoISP

I managed to get it working.

Notes:

  1. I did not have to change anything on the code for the ISP sketch.
  2. Careful with the picture from the first answer, the comments show an issue with the wiring you need to take into account.

After that, the "Burn bootloader" action worked like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.