2

I need to install this library using the arduino-cli software. I don't know what name to use for the library. Using

arduino-cli lib install <library_name>

I have tried Adafruit_MotorShield, Adafruit_MotorShield_V2, and other random combinations and in all cases it cannot found it. In the library manager of the graphical interface it is this one:

enter image description here

5
  • check the name in library.properties
    – Juraj
    Jan 14 at 16:50
  • How do I find the properties of a library?
    – user171780
    Jan 14 at 16:56
  • I found it on GitHub over arduinolibraries.info and it is in the library's folder too if you have it installed elsewhere. And the More Info link in IDE Library Manager goes to GitHub too
    – Juraj
    Jan 14 at 16:59
  • Are you talking about this? Where is the name to use?
    – user171780
    Jan 14 at 17:00
  • Thanks, now I found the library.properties file.
    – user171780
    Jan 14 at 17:04
1

As pointed out by Juraj♦ in the comments, the name to use can be found in the library.properties file. There we find name=Adafruit Motor Shield V2 Library so the command to install the library is:

arduino-cli lib install Adafruit\ Motor\ Shield\ V2\ Library

Note the white spaces are escaped.

2
  • quotes didn't work?
    – Juraj
    Jan 14 at 17:11
  • Don't know, I tried at once with that command, which worked.
    – user171780
    Jan 14 at 17:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.