2

I have a Uno (third party) that I connect to my Dell laptop with no problems at all. But I've just received a Nano (also third party) that I just can't get to upload. After lots of interneting, I hit Windows normally-useless troubleshooting tool. That tells me that the USB device (the Nano) doesn't understand USB3 and I should plug it into a USB2 port. Unfortunately, being a new machine there IS no USB2 port.

Is Windows Troubleshooting lying? Is there a problem interfacing with a Nano via USB3?

Edit: Error message is:

stk500_recv(): programmer is not responding
  • 2
    A third party board may well have a different USB-serial chip than the FTDI part used on a nano from Arduino.cc and so may well require a different USB driver. Your posted error message could quite easily be a result of pointing your software at a serial device other than your arduino clone. – Chris Stratton Oct 11 '15 at 20:27
  • 1
    It happened to me: kongduino.wordpress.com/2015/08/17/where-are-you-clone Turns out that the chip was not the regular FTDI. You might have to look at the USB chip and install drivers for it. – dda Jan 9 '16 at 15:44
  • What USB "controller" is on your Arduino – Paul Apr 8 '16 at 17:21
1

I have run in to similar symptoms while using USB based Arduino clones connected to USB3 ports. Connecting them to a USB2 port on the same PC worked (where this was an option).

For computers that only have USB3 ports, I found that connecting the device via a cheap USB 2.0 hub (not USB3 hub) solved the issue.

I'm not sure why these devices behave like this, but there seems to be something about USB3 ports that these boards don't like.

| improve this answer | |
0

Windows troubleshooter is just trying to tell you that you've plugged a USB2 device into a USB3 port, thus wasting its USB3 capabilities which could be useful for another device. Of course, if you only have USB3, you can't do otherwise.

USB3 is fully backward-compatible with USB2, so whatever your problem is, it is not related to the fact that you plug the Nano into a USB3 port. Perhaps your problem comes from the fact that your Nano is "third party" - I suppose that means it's not the original device and thus it may not be fully compatible. If my guess is right, try to find out what programmer your Nano clone supports: chances are you just need to select a different programmer type in Arduino settings, or buy a separate programmer supported by your device.

| improve this answer | |
  • 1
    While USB3 is supposed to be backwards compatible, that isn't always true in practice. Sometimes using a USB 2 hub in between the computer and a legacy device can make things work where a direct connection would not. – Chris Stratton Oct 11 '15 at 20:26
0

1- Check your COM ports, make sure it is correct

2- Arduino Nano will somethime require a driver, download it

3- Reboot your system and see what happens

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.