1

I have my SIM900 connected to a 12v 2A power source, I have inserted my sim card changed it to 3G/2G(autoconnect) ( I did research it to know wheteher it is possible and it turns out it is, the only problem would be not having the same speed according to them) There are no pin/password on the sim. There is still a remaining balance (should be enough to send a text or two) Also my SIM900 netlight led blinks every 1 sec.

I also did try AT commands that I found on the internet and this is the results:

I have also posted this on this site: https://forum.arduino.cc/t/sim900-at-ccid-error/922283

CODE

#include <SoftwareSerial.h>

//Create software serial object to communicate with SIM900
SoftwareSerial mySerial(7, 8); //SIM900 Tx & Rx is connected to Arduino #7 & #8

void setup()
{
//Begin serial communication with Arduino and Arduino IDE (Serial Monitor)
Serial.begin(19200);

//Begin serial communication with Arduino and SIM900
mySerial.begin(19200);

Serial.println("Initializing...");
delay(1000);

mySerial.println("AT"); //Handshaking with SIM900
updateSerial();
mySerial.println("AT+CSQ"); //Signal quality test, value range is 0-31 , 31 is the best
updateSerial();
mySerial.println("AT+COPS");
updateSerial(); 
mySerial.println("AT+CCID"); //Read SIM information to confirm whether the SIM is plugged
updateSerial();
mySerial.println("AT+CREG?"); //Check whether it has registered in the network
updateSerial();
}

void loop()
{
updateSerial();
}

void updateSerial()
{
delay(500);
while (Serial.available()) 
{
mySerial.write(Serial.read());//Forward what Serial received to Software Serial Port
}
while(mySerial.available()) 
{
Serial.write(mySerial.read());//Forward what Software Serial received to Serial Port
}
}

SERIAL MONITOR

Initializing...
AT

OK
AT+CSQ

+CSQ: 17,0

OK
AT+COPS?

+COPS: 0

OK
AT+CCID?

ERROR
AT+CREG?

+CREG: 1,0

OK

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.