0

Ordered Universal IR Receiver and I got HW-477 module with VS1838B IR Sensor.

Good thing is datasheet for VS1838B is available but not for HW-477.

VS1838B pins as: Ref
Signal | GND | VCC

while HW-477 says:
(- minus) | R | G

Can't understand which one to follow and R is for Receiver? G is for GND and what is - (minus sign) for?

So can anyone help me with ( - R G ) of HW-477 ?

Images:
HW-477 module VS1838B IR Sensor.

These may help?!
this & this one.

Updates:

I looked to trace the Foil (PCB Board Lines) but it didn't worked because the circuit as whole is coated.

Using Connectivity (Continuity (diode test)) option of Digital Multimeter, found these to play beep:

VS1838B HW-477
Signal G & (minus pin of HW-477)
GND (- minus pin of HW-477)
VCC R

But a person in this video saying

- is of course GND

There is a huge confusion which can only be cleared if I got a reply from seniors. I have two of this and can try one (even to burn) to better understand what is going on.

(Tried contacting the vendor about datasheet but they are not responding)

2
  • The only problem I am having is: If I press one button one single time it gives, let suppose this value: Code: 1086138583 but holding it for a second it gives another value of Code: 4294967295 which I don't know is a feature or fault. lol
    – fWd82
    Nov 2, 2021 at 10:51
  • 1
    That's how IR works. The first code is "You pressed the button" and the second is "You're still pressing the button". Not all buttons do it, but things like volume control do.
    – Majenko
    Nov 2, 2021 at 10:54

1 Answer 1

1

The problem here is that HW-477 refers not to the module as a whole but a generic PCB that is re-used (in some starter kits for sure) for many different sensors. I think the idea is that whatever device is attached to the board there's a position where the output is always the same (- = GND, R = VCC, G = Signal). On some variants of the board you can see them labelled as - + S.

1
  • Thank You Sir! It worked. Just a note IRremote library from Arduino by Armin Joachimsmeyer latest version 3.4.0 didn't worked with legacy code found all over web, so I had to install 2.6.0 version and everything is fine now. Just a note so someone will get benefited.
    – fWd82
    Nov 2, 2021 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.