0

How can I fix error code 10 while installing the device driver for Arduino in Windows 8.1? The LED on the board is blinking after connecting it to the laptop, so I don't think so that the board is damaged. What is the cause of this issue?

  • "The board" is more than just the LED and the part that makes it blink. – Ignacio Vazquez-Abrams Feb 14 '15 at 15:31
1

First of all, test if you even need a new driver. On Windows, the Arduino drivers for my Uno and my Mega were installed automatically by Windows. I'd advise to restart your computer, using the actual restart button, not manually shutting off and turning on... this is very important with Windows 8.1 and its Hybrid Boot default!!! A normal reboot doesn't fully reload all of the drivers. Next, open the Arduino IDE, and then see if you can successfully upload the "blink" example sketch.

If that doesn't work, let's try something else.

First of all, open up Device Manager and find your device:

Device manager

It should be under the Ports (COM & LPT) section. After that, right click and click on Properties.

Right click menu

Then, let's go to the Driver tab and click on Update Driver. Then, click on Search Online Automatically for this Driver.

Properties Window

First, try seeing if an automatic update finds any drivers capable. If not, I've found previously that there's sometimes a Reinstall or Fix button somewhere if the driver isn't working correctly.

In addition, you can also update it manually using Device Manager. Instead of clicking on Search Online Automatically for this Driver, click Browse My Computer Manually. For me, there was a Mega driver under the Let me pick from a list of compatible device drivers on my computer and there was a Mega driver for me (although I don't know if that's because I have it installed already).

You can also use that same menu to point it to the location of the installation of the Arduino IDE and it will search for any compatible drivers.

Rolling back the driver is another option if the Arduino IDE tried to install a faulty driver that somehow got corrupt over a working driver installed by the computer.

The last thing I would suggest trying as a last resort is using the Uninstall Driver button and then trying to reinstall the driver manually. I've never done this with an Arduino board, although there have been some times with other drivers that this has helped to remove the faulty driver.

If none of this works, it may be a faulty board.

1

I had the same issue. The drivers, which shipped with Arduino IDE didn't work for me.

Actually, the reason was that I was using Arduino UNO clone. And it required another driver. This video helped me to find the answer: https://www.youtube.com/watch?v=r9MGJ16pRLc

In my case I had to install the CH340 chipset usb driver. The driver can be downloaded from this page: http://www.microcontrols.org/arduino-uno-clone-ch340-ch341-chipset-usb-drivers/

After I installed CH340 driver, the upload from Arduino IDE started working perfectly.

0

After wasting a huge amount of time trying get the Arduino IDE to upload the sketches to my new starter robot I came across the following document in the Arduino Website :"Guide to the Arduino Leonardo and Micro"... In this document they explain how the serial port communication work on the leonardo (which is the ME-Baseboard from MakeBlock)...They state that auto-reset is initiated when the computer opens the serial port at 1200 baud and then closes it... Whatever that means... I went into the makeblock driver setting (under windows 8.1 device manger) and change the baud rate to 1200... Surprise surprise... all works fine now, I can compile and upload the sketches for the starter robot... What frustration !!!! And for the people at Makeblock... I have been trying to create a community userid and while the system say that it will send me an email, it never does !!!

0

I am sad to report that what actually happened it that changing the baud rate also led to a change in board type in the arduino IDE... So the sketch did compile and load but assuming that the board is a UNO. End result, still facing same problem and robot behave a bit erratically probably because the upload was not performed for a leonardo board. I have tried counless times with countless different procedures on an acer laptop with Windows 8.1, an acer laptop with Windows 7 and a surface pro with Windows 7. Same problem everywhere. If someone from Makeblock read this blog, I would appreciate if you could send me the validating email so I engage this troubleshooting process on their community discussion board.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.