I just migrated to a new computer running on an M1 CPU (the new Apple Silicon, arm64 based). I've been searching for CH34x drivers for my TTGO-Lora32 board, but can't find any around, nor can I find mentions of them existing or not. The x86_64 driver installs, but obviously can't run due to it being an incompatible architecture.

Thus, is it currently possible to use a CH34x based board on an M1 Mac?

  • 1
    Turns out there is such driver, but it hasn't been listed yet on the WCH website. I've posted it down below in a new answer.
    – finitud
    Commented Aug 31, 2021 at 12:55
  • It isn't working for me on Monterey. I've tried all the versions installing and uninstalling. It simply doesn't work. No idea why. Commented Feb 10, 2022 at 12:28

4 Answers 4


So they pushed a new version to GitHub late september:


This should be the maintained version ahead of what they offer as a download on the official website.

Common other issues:

  • When reinstalling, make sure to first remove all old files:
sudo rm –rf /var/db/receipts/*CH34xVCPDriver*.*
sudo rm -rf /Library/Extensions/CH34xVCPDriver.kext

also don't forget to check for any related files in /dev/ and the .app file in your applications folder if these already exist.

  • Restart the device before reinstalling.

  • Restart the device after installation.

  • Try a different USB-Cable / USB-Hub.

Note: steps listed here were reportedly solutions I came across during my research which worked for other people and my colleagues. For me it still doesn't work; but I am using a lot of unstable builds for my OS and other software that might interfere.

Update February 2022: Now with Monterey out of closed Beta this works like a charm for me. At least for the Web IDE.

  • 1
    The installer is still requiring Rosetta 2, which makes me worried about the implementation of the driver. Although it might work, it is probably not written for M1 silicon.
    – Rolf
    Commented Sep 22, 2022 at 16:28

After hours of mindless reinstalling of the drivers on M1, reboots and other magic tricks, I almost decided to switch to windows to make my arduino ide work. My NodeMCU board with CH340G would either show up as a serial port or not.

So I leave this message here as clearly many people struggling with M1 end up on this page: buy good microUSB cable. And I mean a good one. All problems disappeared right away. I had three cables at home but none was working - clearly most are only good for charging the phone, but suck at data transfer.

  • Indeed! In my experience, microUSB cables are the most likely to not work as expected.
    – finitud
    Commented Sep 15, 2022 at 7:12
  • ✅ I can attest to this: you need a "data" cable not just a "charging cable". I tried 2 different cables that are just for charging, then I got a data cable and it worked immediately.
    – nodebase
    Commented Nov 23, 2023 at 16:19
  • Big true, I just grab another microUSB cable and all works smoothly. cu.usbserial-210 port appeared right away. Commented Feb 21 at 8:46

As it turns out, I found in the following post:


a link to a particular build of the CH340 drivers that is properly signed and can be installed on the M1 mac with no troubles.

  • 2
    Nice find. Now if only it were listed officially on the CH340 website so people could actually find it. Maybe now it's here it may get more attention from GoogleBot...
    – Majenko
    Commented Aug 31, 2021 at 13:18

Worth the try. The .pkg file from here worked in my High Sierra. I've turned-on the "csrutil enable" before install, and it still worked...:


  • High Sierra is not compatible with M1 macs
    – finitud
    Commented Mar 13, 2023 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.