1

I know this module is super old but the network I am on still uses GPRS so should work.

This is the module: enter image description here I am using the Adafruit example scipt FONAtest. I can connect to GPRS

    <--- SHUT OK
    ---> AT+CGATT=1
    <--- OK
    ---> AT+SAPBR=3,1,"CONTYPE","GPRS"
    <--- OK
    ---> AT+SAPBR=3,1,"APN","live.vodafone.com"
    <--- OK
    ---> AT+CSTT="live.vodafone.com","",""
    <--- OK
    ---> AT+SAPBR=3,1,"USER",""
    <--- OK
    ---> AT+SAPBR=3,1,"PWD",""
    <--- OK
    ---> AT+SAPBR=1,1
    <--- OK
    ---> AT+CIICR
    <--- OK
FONA>

There is credit on the SIM so it has data for sure, I can also send SMS.

There are several different approaches people seem to take (altering AT commands) to persuade this device to work, pretty sure I have tried all of them :) I always get a timeout when trying to read or GET a webpage.

I have tried several combinations via terminal and I seem to connect ok but get no further. It has worked once, but that was in a different part of town.

How do I check that the GPRS is actually connected? Any troubleshooting tips?

There is a dedicated 2A 5V connected to the unit, it isn't dropping out AFAIK. Do you have a rock-solid AT sequence that always works?

Also, there seem to be SAPBR commands that don't work at all, not sure why?

1
  • 1
    You should check whether the GPRS is attached with AT+CGATT?, after sending AT+CGATT=1, if it return +CGATT: 1, it means it is attached and you can proceed for the next step.
    – hcheung
    Jul 24, 2021 at 5:16

2 Answers 2

1

It highly depends on the URL you are trying to fetch.
Those modules DO NOT understand secure HTTP/S. They only understand plain unsecure HTTP.
Most web pages nowdays don't offer unsecure HTTP access and always redirect the request to a HTTP/S server. So in my opinion the usefulness of those devices is very limited when it comes to internet access.

If you have full control over the web server you should disable the enforcement of a secure connection.

Beyond that. The sequence you posted is just for activating GPRS.

I also found the FONA sample for fetching a page not very reliable but I was able to request the page multiple time. Perheps you have your module in a place with low signal strenght. Does your module offer an u.fl connector for a better antenna?

2
  • It does have a u.fl connector and I have the bundled antenna attached. The RSSI is -89 which I think isn't great. The code I always get is 603
    – maxum
    Jul 23, 2021 at 10:09
  • I do have control over the webserver and it is http
    – maxum
    Jul 23, 2021 at 10:10
1

Don't know why, I had to manually set the DNS t0 8.8.8.8 using AT+CDNSCFG?

It had DNS entries in there but they didn't want to resolve for some reason.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.