1

I am new to Arduino and I have ran into an issue. When I first tried to plug the arduino nano (after market, from ebay) into my computer (Macbook pro M1), nothing happened. Then I downloaded the cp210xVCP Driver. After that, when I plugged in the nano, the /dev/cu.usbserial- 1110 appeared. But when I try to get board info noting happens. It's like the computer recognize there is something, but does not know what. I believe Arduino is not fully compatible for M1 macbooks, but is there something I can do to fix this?

 fi

2
  • 1
    Have you tried uploading a sketch now your board is detected by the OS?
    – Majenko
    Jul 16 at 9:51
  • 1
    My Arduino clones don't give any Board Info either, so this might be not related to just M1 Macbooks... Jul 16 at 10:16
0

Majenko and Python Schlange have the right of it I think. This is a common and well documented phenomenon. Check out the comments on the Arduino forum by the arduino team which explain PIDS and VIDS on USB equipment and why the clones appear differently. It shouldn’t (all going according to plan) make a difference other than the board information not being present as you’ve noted. That’s why Majenko is suggesting you go ahead and upload a sketch. The Blink example sketch is frequently used for this as a first board test when you receive something new.

See also USB FT232 driver on M1 mini for more information about checking USB ports on the Mac.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.