My custom board with Atmel SAMD21 microcontroller (same as Arduino MKR Zero) is not making a USB port since yesterday. The board was working fine before that.

Please suggest ways to resolve this issue. What are the possible reasons for such an issue?

Since reset is equivalent to powering the board ON and OFF which has not resolved the issue, can burning the bootloader again help?

Further information:

  1. The board seems fine. It powers ON and OFF in the usual manner.
  2. This problem with the USB port connection happened while I was trying to upload the code.

The USB pin connections on the board have been checked as well as tested with different USB wires.

Appreciate your help.

  • Does this answer your question? Why is the IDE not able to find the board despite it being clearly seen and selected?
    – Juraj
    Jul 8, 2021 at 5:03
  • 1
    Press reset twice to activate the bootloader.
    – Majenko
    Jul 8, 2021 at 7:29
  • The custom board does not have a reset button. Is there another way to get into the bootloader mode? Also, there is a GPIO pin-out for reset pin. Will burning the bootloader again help with the problem? Jul 8, 2021 at 9:46
  • 2
    A wire can do the job of a reset button.
    – Majenko
    Jul 8, 2021 at 12:58
  • Yes, this worked. Appreciate your help Majenko ! :) Jul 16, 2021 at 7:29

2 Answers 2


Solutions to the problem:

  1. External Hardware Reset -- using a reset button (that I externally managed to solder using the Reset pin-out) -- to get into bootloader mode and start the program from the beginning

Thanks Majenko, from the comments.

  1. Burning bootloader again may also work (theoretically) - I have not tried and tested it.

For detailed understanding - follow this post - https://forum.arduino.cc/t/atmel-samd21-microcontroller-not-making-a-usb-port-anymore/882504/5


What are the possible reasons for such an issue?

I noticed that calling


in the script can cause this.

See post Seeeduino XIAO stopped connecting - Enter Bootloader Mode is not working

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.