1

I recently purchased 5 Arduino Nano clones and on my Windows PC they were all working fine. I then gave one to a friend and after installing the CH34OC driver on his Mac he was able to program a simple Morse code blink program that worked fine on the device. However, after uploading it the COM port was no longer showing and his Mac could no longer detect the device.

We verified that the problem was not with the Serial cable and not with the USB port and other the Arduino clones worked perfectly also. So it must be an issue with the device which when connected the RX and TX lights would stay on and the inbuilt LED would display the Morse code as was programmed. The device would then no longer even be registered by my computer as no noise was made when plugging it in and nothing showed up in device manager as if I simply pugged in a USB cable with nothing attached.

I then used my Arduino UNO to run the Arduino ISP program and then burn the bootloader onto my NANO. This was successful and the a new blink program was loaded and the TX light no longer shows when connected to my computer but it is still entirely undetected as if nothing was plugged in.

I have tries many things including but not limited to:

Holding the reset button when plugging it in

Reinstalling the driver as administrator

Switching out the cable

Changing the USB port

Using the old bootloader

Reinstalling the Arduino IDE

Restarting my computer.

Sadly nothing is working and I am out of ideas. Does anyone have any suggestions for a fix or know how I can diagnose the issue further. For example checking to see if the USB chip on the Arduino is operational or maybe the diode was faulty? Methods for testing these things would be greatly appreciated.

1 Answer 1

1

It sounds rather like a fault with the Nano's CH340 chip, the one used to communicate over USB between the Nano and a PC. The Atmega 328p seems to be working, as you say the previously loaded Morse Code program still runs. I expect you can still program the Atmega entirely through its ISP.

If the CH340 has been physically damaged, you can still program the Atmega processor via the ISP but you will no longer have USB capability on-board. You could use a CH340- or FTDI-cable (USB <-> TTL serial) connected to Arduino-pins 0 and 1 to provide off-board USB communication if you want to continue using the Nano as usual.

Update:

Is there any way that I can verify that the CH340 chip has indeed been damaged as if it is something smaller like a diode I may attempt to repair it.

I don't know of a way unless a visual inspection shows a bad component. Not that there might not be one, just that that level of board repair is beyond my expertise. And assuming you didn't ever see or smell smoke, I wouldn't expect the defect to be visible. No harm in going over it with a strong magnifier, though....

2
  • 1
    So I am assuming my best course of action will simply be to program it through ISP then place it in a permanent project.
    – dajaco81
    Jul 8, 2021 at 1:06
  • Is there any way that I can verify that the CH340 chip has indeed been damaged as if it is something smaller like a diode I may attempt to repair it.
    – dajaco81
    Jul 8, 2021 at 1:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.