1

PT100 (3 wire) is connected to arduino uno as i believe i have them connected properly, i have checked other forums such as changing the capacitor to ferrite core, and probably changing up to 4 breakout boards to get the same result (getting crazy). I also tried switching 3,3v to 5v repeatedly and hence i would get various errors such as the following:

I am using the example from the adafruit example available from adafruit library with the instances:

Adafruit_MAX31865 thermo = Adafruit_MAX31865(10, 11, 12, 13);
// The value of the Rref resistor. Use 430.0 for PT100 and 4300.0 for PT1000
#define RREF      4300.0
// The 'nominal' 0-degrees-C resistance of the sensor
// 100.0 for PT100, 1000.0 for PT1000
#define RNOMINAL  1000.0

void setup() {
  Serial.begin(115200);
  Serial.println("Adafruit MAX31865 PT100 Sensor Test!");
  thermo.begin(MAX31865_3WIRE);  // set to 2WIRE or 4WIRE as necessary
}

and the error i always got:

RTD value: 0
Ratio = 0.00000000
Resistance = 0.00000000
Temperature = -242.02

Might not very an engineering way to troubleshoot things but i ordered the original adafruit MAX31865 breakout board instead. Here is my setup Setup View

3
  • It looks like everything is hooked up correctly (assuming the trace cut and blobs on the sensor breakout are solid), but it'd be easier to understand the wiring with a schematic. You say you're using the PT100 but you're using the resistance value for the PT1000, which might matter. Hard to say if the sensor is wired to the board correctly. AFAIK you'd need to use only 5V power so the data aligns w/ the Uno's expected input ranges. – Dave Newton Jun 16 at 12:51
  • Thank you, would it be better to put some info that i knew about connecting the pt100 with the board? and yes apparently i forgot to change the RNOMINAL 1000.0 to RNOMINAL 100.0 but i would still get the same results: error. As far as i know i have tested the pins of the pt100 with a multimeter to measure its resistance, between the blue-colored ones they are 2 ohm resistance. and between the red and the blues, they have around 109 ohm resistance, and this should be the part of the difference of the temperature measurement. – Lactobacillus Jun 16 at 14:23
  • I would remove private: from the class and use the now available readRegister functions to see if the the chip is communicating correctly at all. E.g. read the configuration register mentioned in the datasheet with readRgeister8 after the begin() call and see if the contents of it make sense. Use of the writeRegister function to change one, and then read it back and see if it comes back. – timemage Jun 16 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.