0

I have some problem with Arduino uno and asked here, so I have tried to work by my STM32F103C8 as alternative board, and solved my problem by this question:

Arduino Port Not detected and can not run it as root

But now I as seeing that the Arduino port again is not acceptable but I can upload the codes into the STM32F103C8 board, so I asked why this happen ?

enter image description here Note : I have seen this post which the STm32F103C8 board have some port on Arduino IDE (as you can see below ):

enter image description here

Update:

I have seen The below post about the same problem as you can see below:

Can't open serial monitor using ST Link and STM32F103C8

But, based of the last part of above post,which is shown below, I don't get have could i have enable the serial port connection for the STM32f103C8 Board:

I did everything as it was described in tutorial, flashing bootloader was succes, everything went ok, but windows still can't recognize it. I am thinking that maybe it is problem with that resistor and maybe i have to mod it... I think I will be sticking to ST-Link for uploading codes and USB-UART for serial. But thanks for help

And one more question, can you tell me how to reset my Blue Pill to factory bootloader (how to delete stm32 bootloader that I installed)

Thank.

2
  • it doesn't work. only the tool reports a wrong result
    – Juraj
    Jun 14 at 17:23
  • Is there a default that it tries to transmit the sketch to if no ports are selected? Jun 17 at 1:14
1

The STM32F103C8 has a native USB interface. You will only ever see a CDC/ACM (USB UART emulation) interface if you actively run code that implements a CDC/ACM interface.

The bootloader is separate to your code. I don't know what protocol the bootloader for your board uses, but it may not even have a CDC/ACM interface to it.

In short: it doesn't have a port because you haven't programmed it to have a port, and the code uploading doesn't use a port, so doesn't care.

4
  • Thanks, but was is the means of /dev/2 on the Arduino IDE result which shown here?!
    – so sa
    Jun 15 at 8:27
  • It'll be something specific to dfu-util. Btw, dfu is a custom protocol that has no serial or anything like it.
    – Majenko
    Jun 15 at 9:09
  • So You are saying, For enabling the port option in Arduino IDE, I must burn some boatloader to the STM32f103c8 board by Arduino IDE or other software?
    – so sa
    Jun 15 at 19:54
  • No, you just write a sketch that uses the usb serial.
    – Majenko
    Jun 15 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.