I'm trying to figure out how to program my new Raspberry Pico with Arduino, but don't see a port to select so I can't upload the blink sketch.

Here's what I've done:

  • The Pico is working, I can program it with micro Python.
  • Just in case, I brought the Pico back to factory settings with the nuke file.
  • Installed support for the Pico in Arduino IDE. Version 2.1.0 of Arduino MBed RP2040 is installed.
  • While keeping BOOTSEL pressed, I plug in the Pico to my laptop (Ubuntu 20.04)
  • The board selected is "Raspberry Pi Pico"
  • But the option to select a port is greyed out :-(

It seems that I am omitting some step during the installation, but can't figure out what it is.

Any ideas?


2 Answers 2


I've come across this and this is how I worked around it (on Windows, but I suspect the problem and solution is the same).

A brand new Pico or one not programmed by the Arduino IDE does not have a serial port, which is why you can't see one. Arduino sketches are compiled with a serial port automatically, so once a serial port exists, it can be used for future uploads.

The Arduino solution is to use the 'Export compiled binary' option (for any sketch) and upload the UF2 file (which should be generated into the sketch folder) using virtual USB drive interface. When the sketch starts, the serial port will be available and can be used for future sketch uploads.

Another solution is to use an alternative Pico core. This one does not need the port selected, but will find and upload to a Pico in bootloader mode via the virtual USB drive.


Had this issue and tried everything that was described on forums.

The thing that worked for me was: I held the bootsel button until it opened pico folder, then port button activated in the IDE and I chose UF2 port and then after upload, pico showed at COM7

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.