2

I'm trying to get the Arduino IDE (1.8.13) installed on MacOS BigSur 11.0.1 and am unable to compile and run an Arduino sketch. There are no ports available in 'Tool' menu; the port item is grayed out. The error message states that the IDE "Could not initialize class sun.security.ssl.SSLContextImpl$DefaultSSLContext". I have installed the following Java code:

java 16.0.1 2021-04-20
Java(TM) SE Runtime Environment (build 16.0.1+9-24)
Java HotSpot(TM) 64-Bit Server VM (build 16.0.1+9-24, mixed mode, sharing)

Any insight would be most appreciated. Thanks in advance.

6
  • I don't have a Mac, so I'm not likely to be of much use on this, but it would be good to confirm that the device shows up in /dev or whatever is in the Mac control panel that lists USB devices. If it doesn't, then the SSL error is unrelated (which would kind of make sense) or, at a minimum, not entirely determining the problem. – timemage May 2 at 23:33
  • 1
    @timemage serial ports are listed in /dev. – apodidae May 3 at 0:11
  • Solved: I opened Android Studio and there was a security update for Java 8 (I think) so I accepted it and installed it. Now I can magically see serial ports in the Arduino IDE. I wish I understood what happened, but for now the problem appears to be solved. Thank you for allowing me to post here. – apodidae May 3 at 2:28
  • Odd. The way the IDE comes packaged, at least for Linux and Windows, it has its own JRE bundled in. – timemage May 3 at 3:02
  • With all the gatekeeper features on a Mac, perhaps it blocked the Java code when I downloaded the Arduino IDE? Macs used to come with Java pre-installed, but I've read that they no longer do that. It is a new 64 bit machine and I have to give special permission just to run my own apps developed and compiled on my old 32 bit system. – apodidae May 3 at 3:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.