0

I have a RFID module using NXP RC522 chipset. Chipset

I have no idea that is it correct the module using 27.120 mHz 27.120 mHz

And I have 4 IC card,

A) 0005302176, (Blue color tag, come with the RFID module)
B) 0008846830 134,65006 (White card, come with the RFID module)
C) 0004189112 063,60344 (White card)
D) White card, no number print on the card. Only this card UID can be read.

4 IC Cards

Here is the pinout Pinout Which I connected to Arduino UNO R3

     RFID         UNO R3
(Pin Name, Pin)    (Pin)
SDA        1        10
SCK        2        13
MOSI       3        11
MISO       4        12
IRQ        5        -No Connect-
GND        6        Ground
RST        7        9
3.3V       8        3.3V

PS: I am using this library, and this example.

PS: The serial return this information MFRC522 Software Version: 0x91 = v1.0

  • 1
    Can you clarify what the problem is please? – Peter Bloomfield Jan 30 '15 at 14:51
  • Why I can read 1 card UID only, but others three cards UID unable to read. PS: the blue tag was come with the module, but still can't read UID, am I something go wrong? – Allen Chak Jan 30 '15 at 15:00
  • It's probably the fault of the cards, they are very cheap and I have had a few with dead cards. You seem to have a whole pack of dead cards. You could try with a contactless payment card, transport card, or staff access card from work. – unknowndomain Feb 2 '15 at 23:34
  • @unknowndomain, I had tried my two staff access card. These card also printed numbers, and I have 6 white cards (both can read UID and both nothing printed numbers). Could anyone can answer me that the module should able to read the cards which printed number, or module never read the card UID except white card. Or someone answer me that, I should enter the SN (Maybe on chip/card) for reading Card UID. – Allen Chak Feb 3 '15 at 4:21
  • I presume you are aware that different cards use different technology and only some are compatible with this reader, that said the ones that came with it should work. – unknowndomain Feb 3 '15 at 13:47
1

Check your power source, if you are powering the module from arduino/USB=>part or something like that, there can be not much power for the module. Also you can try powering it 5v (not 3,3 as they should be powered by reference).

In my case I have had problems reading some types of cards, and I have solved that problems by giving better power supply, also higher power supply than in reference for some of the cards.

"By magic" the cards that were not working started working as a charm.

Also you should check if the cards you are using are all ISO14443 A

Only that kind of cards is compatible with that reader. So if you got type B, or other type of ISO cards, that will not be working. Some of them may use different frequency, there is a bunch of standards around.

Also as said before the cards can be damaged, or could be corrupted if you tried reading UID while writing to the card, the problem is known , and in that case you can damage the UID.

I hope it helps you. cheers

0

The MFRC522 reader is for 13.56 Mhz tags; these tags normally dont have the UID printed on them, in my experience. 125khz cards, however, usually have their SNs printed on them; as you can see all the cards that didnt work, have a 10 digit SN that seems to follow the same pattern. These card SNs can't be read by the MFRC522, as they follow a different protocol. When you buy a tag/card, make sure that its a 13.56 Mhz tag (look for Mifare tags), if you want the MFRC522 to be able to read it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.