0

I just received my first Arduino board which is essentially a Leonardo (ATmega32U4) customized to include a NFC reader (PN532).

When I plug it in, the PWR LED comes on steady, the D13 LED flashes a few times, and then the STA LED blinks once and only the PWR LED is left on. I can upload a basic sketch to the correct Serial Port, but the Serial Monitor is always empty.

I have noticed that, when uploading the sketch, the RX/TX LEDs stay off (which I thought was a sign of uploading/downloading data). I figured this was the root of my issue so I tried to look into it further. Running lsusb does not find the device and dmesg does not show any information when (un)plugging the device.

I also tried on a Windows install, but couldn't install the Leonardo drivers since Device Manager wouldn't register any unknown USB/Arduino devices.

Do you think my board is dead on arrival or am I doing something wrong?


Update:

I just uploaded the Blink tutorial sketch and it uploaded "successfully" but I noticed no differences. Please note that I don't have an external LED attached, but am looking at the board's LED on pin 13. This pin already flashes a few times (as mentioned above) on a reset, so I modified the delay times and still noticed no change.

uploaded sketch

I am uploading using board Leonardo, as recommended for my hardware, and the serial port /dev/ttyS0. I thought this was the right port because I remember not seeing it at first, but on second thought I had a permission issue at first (which is now resolved) causing me to not see the port.

So it looks like my board is not detected by my computer and I'm successfully uploading sketches to a meaningless port. Any troubleshooting options for me? I've tried different USB ports and am, as of recently, plugging my board into external power (9V). The only thing I can think of that on my end is that I'm using a Y-cable for my USB connection (I have a normal Mini-USB coming tomorrow via Amazon) since it is all I had. I can also confirm that this USB connection does power the board when plugged in.

  • Something is inconsistent in your description - either the board is recognized, or else you cannot upload to it. – Chris Stratton Jan 27 '15 at 1:32
  • 2
    I'll say again, something is inconsistent in your report, as you cannot upload to a USB device which is not detected by the operating system. There's something you aren't accurately reporting, and it is key to solving your issue. Perhaps you are mistaken in thinking you managed to upload something? To what serial device node did you allegedly upload? – Chris Stratton Jan 27 '15 at 4:03
  • 1
    Further to that, can you upload a demo such as 'blink' & have it flash an LED at you to confirm it's taken the upload? – Mark Williams Jan 27 '15 at 10:08
  • 1
    @chrisStratton -- thanks for forcing me to look at this again, this is my first time really messing with hardware. Please see my update. – Sam Jan 27 '15 at 15:53
  • 1
    /dev/ttyS0 is a serial port - not a serial-via-USB - and so will be looking for something plugged into a 9-pin D socket (or 25-pin; if you even have one at all) - this may well explain things, although there is meant to be 2-way comms. I'd definitely check the cable as Arduino boards lighting up & flashing is a good sign! Do you not have a printer cable or something you can 'borrow'? – Mark Williams Jan 27 '15 at 15:59
1

So, to summarise the comments trail; the blinking lights at power-up are the normal boot sequence for the Leonardo, indicating the processor is good, and that power is reaching the board; the device seen should be /dev/ttyACM0 or some other number; dmesg wasn't recording a plug-in event as the cable was not good.

We still don't quite know why the IDE thought it had sent a program to /dev/ttyS0, but presumably the level of interaction is much less (ie, none) via RS232 serial? Which explains why it said it had uploaded a test program when, in fact, it hadn't!

And replacing the USB cable has solved the problem - excellent news!

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.