0

I have a Freeduino USB 1.1 board with atmega 8l-8pu microcontroller on it. When I try to upload program, it shows error:

avrdude stk500_getsync() not in sync: resp 0x00

I have tried reset and the red led blinks which I think suggest bootloader is working fine.

On Arduino IDE, I have set Arduino Uno and correct port which is shown in device manager.

One weird problem that I noticed is that no matter which USB port I connect to, it says COM9 on device manager. Is that something to look into?

Any ideas?

  • Do you have anything plugged into the RX/TX pins? That has tripped me up a few times. – Nathan Jan 27 '15 at 8:20
  • @Nathan nope.... – Nigel Jan 28 '15 at 12:21
0

There could be many reasons for the problem you have got.

1) Try to program your Board with any other device you have got. If you are trying to program it with PC try to do it using Laptop.

2) Plug your board to any other port. Then Right Click My Computer and Select Manage--> Device Manager and find the port where your Freeduino is connected. Then Select that port in your Arduino IDE.

Solution 1 worked for me!

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.