Arduino suddenly stopped being recognized. It is not listed in /dev and dmesg -w shows no activity at all when un/plugged.

I'm on Fedora 33. The Arduino is MKR-Zero. The cable is ok - other devices work well. I tried it on windows machine - same result - in Arduino IDE the option for port is greyed out.

Very weird thing happened before this issue- when I was trying to flash sketch, audio connected to docking station switched to speakers in laptop and keyboard + mouse connected to the docking station powered down (back light on keyboard went off and could not be turned on) however the Num lock light was on.

I'm afraid that I burned the Arduino - how do I verify if that is the case. The "ON" LED is lit up when plugged in


1 Answer 1


Ok, I have no idea what the hell is this, but when I double-press the reset button (while connected/powered on ofc) it works again. This can be seemingly cycled - press once and it goes wrong, press twice and it's ok again... round and round. Seems more like some retarded "feature"

  • 2
    It's a good feature that lets it stay in the bootloader longer for when you've screwed up the application area (sketch) so badly that it just drop off USB before you can put something else on it.
    – timemage
    Mar 11, 2021 at 12:56
  • Dumb bastards put it at the top of the frequently asked questions list on the product page were you certain to never find it. =P
    – timemage
    Mar 11, 2021 at 13:02
  • It would be nice to have it in documentation, but why bother, right? Mar 11, 2021 at 14:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.