1

I have 3 arduinos that I want to program on, all of them with their own cable and I have tried to connect them to my laptop on several different usb ports, my usb ports work with mouses so that's unlikely to be the problem. However I just cannot connect to them they just don't appear under /dev/ttyACM* and the arduino IDE cannot find them either. I'm running ubuntu 14.04 any suggestions for finding out what is likely to be wrong with my system or the arduinos?

For some odd reason they now all appear to be seen as /dev/ttyACM* but they now all give me a

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

error

Anybody have any idea how to fix? The arduino's do not have any wires in them except usb (nothing in reset or any other pin), I'm on ubuntu so the drivers shouldn't be an issue? And pin 13 flashes when I reset the arduino.

  • Are these Arduino clones? – PhillyNJ Jan 22 '15 at 15:19
  • One is an official arduino one is a funduno and one is a "uno" (no other marking) – Thijser Jan 22 '15 at 15:46
  • Take a look at this video - Check and see if they are bricked youtube.com/watch?v=RZH_qGautqM – PhillyNJ Jan 22 '15 at 16:15
  • I'm working from ubuntu 14.04 not from windows so I don't think that tutorial will work – Thijser Jan 22 '15 at 16:20
  • 2
    Absolutely no need to waste time with windows (you would learn less there anyway) Look in dmesg when connecting and compare lsusb output with and without them connected. Note that many chips will show up as /dev/ttyUSBn not ttyACMn. In theory you could be missing drivers or lack a udev rule for permissions, but ubuntu should be set up right by default. – Chris Stratton Jan 22 '15 at 17:17
1

it's been a while but a long time later I found that the cable I was using was broken. A different cable worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.