1

I am using Raspberry Pi 4 to connect via usb to program ardino Nano, I intend to communicate with the nano via i2c, but this is irrelivant.

With a fresh install of Arduino for ARM 32 bit I get this error when tring to compile a default (fresh) script:

Arduino: 1.8.13 (Linux), Board: "Arduino Nano, ATmega328P"











/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/arduino-builder -dump-prefs -logger=machine -hardware /home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware -tools /home/pi/Desktop/arduino_32_bit/arduino-1.8.13/tools-builder -tools /home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr -built-in-libraries /home/pi/Desktop/arduino_32_bit/arduino-1.8.13/libraries -libraries /root/Arduino/libraries -fqbn=arduino:avr:nano:cpu=atmega328 -vid-pid=1A86_7523 -ide-version=10813 -build-path /tmp/arduino_build_228832 -warnings=none -build-cache /tmp/arduino_cache_202507 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr -prefs=runtime.tools.avr-gcc-7.3.0-atmel3.6.1-arduino7.path=/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr -prefs=runtime.tools.avrdude.path=/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr -prefs=runtime.tools.avrdude-6.3.0-arduino17.path=/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr -prefs=runtime.tools.arduinoOTA.path=/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr -prefs=runtime.tools.arduinoOTA-1.3.0.path=/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr -verbose /tmp/untitled1895295462.tmp/sketch_feb16a/sketch_feb16a.ino
/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/arduino-builder -compile -logger=machine -hardware /home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware -tools /home/pi/Desktop/arduino_32_bit/arduino-1.8.13/tools-builder -tools /home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr -built-in-libraries /home/pi/Desktop/arduino_32_bit/arduino-1.8.13/libraries -libraries /root/Arduino/libraries -fqbn=arduino:avr:nano:cpu=atmega328 -vid-pid=1A86_7523 -ide-version=10813 -build-path /tmp/arduino_build_228832 -warnings=none -build-cache /tmp/arduino_cache_202507 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr -prefs=runtime.tools.avr-gcc-7.3.0-atmel3.6.1-arduino7.path=/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr -prefs=runtime.tools.avrdude.path=/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr -prefs=runtime.tools.avrdude-6.3.0-arduino17.path=/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr -prefs=runtime.tools.arduinoOTA.path=/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr -prefs=runtime.tools.arduinoOTA-1.3.0.path=/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr -verbose /tmp/untitled1895295462.tmp/sketch_feb16a/sketch_feb16a.ino
Using board 'nano' from platform in folder: /home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/arduino/avr
Using core 'arduino' from platform in folder: /home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/arduino/avr
Detecting libraries used...
/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr/bin/avr-g++ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10813 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR -I/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/arduino/avr/cores/arduino -I/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/arduino/avr/variants/eightanaloginputs /tmp/arduino_build_228832/sketch/sketch_feb16a.ino.cpp -o /dev/null -DARDUINO_LIB_DISCOVERY_PHASE
Generating function prototypes...
/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr/bin/avr-g++ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10813 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR -I/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/arduino/avr/cores/arduino -I/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/arduino/avr/variants/eightanaloginputs /tmp/arduino_build_228832/sketch/sketch_feb16a.ino.cpp -o /tmp/arduino_build_228832/preproc/ctags_target_for_gcc_minus_e.cpp -DARDUINO_LIB_DISCOVERY_PHASE
/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/tools-builder/ctags/5.8-arduino11/ctags -u --language-force=c++ -f - --c++-kinds=svpf --fields=KSTtzns --line-directives /tmp/arduino_build_228832/preproc/ctags_target_for_gcc_minus_e.cpp
Compiling sketch...
/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/tools/avr/bin/avr-g++ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -MMD -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10813 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR -I/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/arduino/avr/cores/arduino -I/home/pi/Desktop/arduino_32_bit/arduino-1.8.13/hardware/arduino/avr/variants/eightanaloginputs /tmp/arduino_build_228832/sketch/sketch_feb16a.ino.cpp -o /tmp/arduino_build_228832/sketch/sketch_feb16a.ino.cpp.o
Assembler messages:
Error: unrecognized option -mmcu=avr5
exit status 1
Error compiling for board Arduino Nano.

I am not sure if it's related, but when I try sudo ./install.sh I get the result

pi@raspberrypi:~/Desktop/arduino_32_bit/arduino-1.8.13 $ sudo ./install.sh
Adding desktop shortcut, menu item and file associations for Arduino IDE...

touch: cannot touch '/root/.config/mimeapps.list': No such file or directory
/usr/bin/xdg-mime: 848: /usr/bin/xdg-mime: cannot create /root/.config/mimeapps.list.new: Directory nonexistent

 done!

But arduino studios runs by the script in the folder. I have tried selecting different Programmers with the same result. I am using arduino arm 32 bit as the 64 bit arm version does install with no error, but it does not start with the script.

Thanks in advance for any ideas on how I can fix this

6
  • I would download the Linux ARM 32 IDE and look at something in it to troubleshoot, but their donation screen doesn't want to let me by today.
    – timemage
    Feb 16, 2021 at 0:52
  • If you follow the menu back to downloads page, then try again it lets you past. Or click downloads.arduino.cc/arduino-1.8.13-linuxarm.tar.xz
    – Arcanist
    Feb 16, 2021 at 1:06
  • Familiar with that. Went through quite a few times. They're just getting more obnoxious with it.
    – timemage
    Feb 16, 2021 at 1:10
  • Well, you can try getting it to download a different version of the AVR core files in the package manager. Or perhaps dig around in the result of running strace -f on an execution of avr-g++ with file containing nothing but int main(){} See what (avr-)as it is running. Kind of sounds like it's locating the wrong assembler, assuming it's really the assembler and not the linker that's actually complaining.
    – timemage
    Feb 16, 2021 at 1:52
  • Thank you for your reply timemage, I installed an old version of Arduino (1.8.6) and I use the old bootloader and it works. (Probably should have tried that first, whoops) Sorry, I'm too new to Linux and avr to know how to run an execution of avr-g++
    – Arcanist
    Feb 16, 2021 at 2:09

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.