I am pretty sure this device worked yesterday. I tried to short GPIO0 to ground (flash), nothing. I have a second ESP that uploads fine, but this one does not.

Is their another way to get this bootloader to open up? Or am I the owner of a brand new door stop?

  • 2
    show the complete wiring. is it a board or a basic module?
    – Juraj
    Jan 27 at 5:24
  • "doorstop", heh; maybe for a dollhouse ;) Does serial monitor show anything, like garbage, when you reset it attached?
    – dandavis
    Jan 27 at 6:35
  • @Juraj It's USB. I should have been more specific. There is no way to screw it up.
    – brad
    Jan 27 at 11:22
  • @dandavis Yes, I see a single line of garbage going across the screen in the serial monitor.
    – brad
    Jan 27 at 11:23
  • sorry I missed D1 mini in the tile. is something wired to the board?
    – Juraj
    Jan 27 at 11:34

I'm not sure if this will help EVERYONE, but I hope it at least helps someone. I had the same issue with several different boards (3 Nano's, 2 NodeMCU ESP8266's, and 1 Uno). I searched and searched for an answer and I kept reading about this pin or that pin being "pulled low" or "pulled hi" interfering with uploading sketches. Well, since I couldn't find a solid answer anywhere I decided to disconnect all of the peripherals hooked to my board (except for powers and grounds) and Wah Laa!!! The sketch uploaded like it was supposed to. So, I believe if you just unhook all of the sending and receiving pins from all of your peripherals during upload, the sketch should upload just fine. I hope this helps you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.