1

I purchased a DigiSpark attiny85 off of ebay. Over the weekend I tried to get my computer to recognize the DigisSpark, but it won't recongnize it. When I plug the device in, the 'Device Connection' Sound alerts me and then a second or two the 'Device Disconnection' Sound alerts, then 'Device Connection' Sound, then the 'Device Disconnection' sound. This happens until I unplug the device. The light does turn on, but Windows (10) doesn't recognize the device, it just loops the sounds.

I am trying on a Windows 10 machine. I installed the drivers from the DigiStump Github: https://github.com/digistump/DigistumpArduino/releases/download/1.6.7/Digistump.Drivers.zip

I do see 'Digispark Bootloader' in my device manager for a couple of seconds in my device manager.

I tried different cables. I tried to install the drivers on another computer and the same thing happens.

What should I try next? Am I missing other drivers?

1
  • You can make the Device Manager to show unconnected devices (or whatever term it uses, I don't have an English Windows). Check there for the device. Jan 19 at 7:53
1

Unless, during the short time it shows in device manager, you see that it is missing a driver, it would seem you don't need to do anything further with drivers. You didn't mention it saying it was missing a driver or as an "unrecognized" device, so I'm guessing you mean it doesn't stay recognised or that it isn't recognized as a serial device. If I'm incorrect in that, do say. The fact that it is showing in device manager for any length of time suggests that your cables are fine.

I'm not a Digispark user, but as far I can understand what you're saying, the connecting and disconnecting (once at least) is expected behaviour:

In addition remember the Digispark only shows up as a programmable device for 5 seconds, after that it will start running its code (when it is new and un-programmed this means it will blink) and disappear or act like the USB device you programmed it to act like.

If anything in the sketch (or lack thereof) causes the board to reset or jump to the bootloader, it would continually reconnect for 5 second intervals. They documentation suggests should blink, as in run a blink sketch that was put on the board before you received it. But then you got this from ebay, so who knows what they did or did not put on it. I haven't studied the micronucleous bootloader enough to know, but it wouldn't surprise me if it jumps to the sketch area irrespective of whether or not it's unprogrammed. If it is unprogrammed then it is probably nop-sliding, for lack of a more appropriate term, right back into the bootloader.

You're not going to see it recognized as a serial port device like a typical Arduino. The bootloader uses a vendor specific protocol that will not list as a COM# (or /dev/ttyXYZ#) device.

Indications are that if you compile the blink sketch and "upload", the IDE will run the micronucleus programming tool which gives you a 60 second window for you to plug the board in, at which point it will load the board with the blink sketch. After which it should blink the LED. If unplugged and replugged, you can expect it to show up for 5 seconds on USB and if left alone should disconnect (electrically) from USB and begin blinking.

1
  • You are correct. I was following a youtube video and the video was showing something else. Went to another tutorial and the device behaves as it does with mine.
    – Peter Sun
    Jan 19 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.