1

I searched for answers on StackExchange but did not find any for the situation I am in.

I use a macBook pro to connect the recently procured Nano33 BLE sense via a USB cable.

I tried a couple of sketches and all worked well. I then became a bit ambitious to try the this example:

The IMU capture went well trouble started when I used the IMU Classifier program

On the first attempt - I was able to compile and upload the classifier sketch and I could an initial response from the setup() on my serial monitor and after that nothing happens.

I suspected some serial comms issue so I tried the IMU Capture program just to see if all communications on serial port was normal - but was unable to upload the program and Arduino IDE did not give any error. It just kept saying uploading and the time taken was much longer than normal.

At this stage the Green LED is on, and Yellow keeps blinking.

As a result I am unable to replace the IMU Classifier program that was previously loaded and possible is the cause of issue with serial port.

I also checked if I can read board info - and that works (implying that there is some communication between macbook and nano33.

I restarted both macbook and nano33 but still cannot replace the program in the Nano with a new sketch.

What else can I do unlock this stalemate?

EDIT: found this issue logged (but still unresolved on GITHUB)

Question : Is there a way to erase the current program on nano33 outside of Arduino IDE?

EDIT: found a solution to reload sketch

1
  • 1
    use double reset to start the bootloader mode and upload a working sketch – Juraj Jan 7 at 6:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.