2

I'm working on building an LED matrix and I'm using an LED strip to create it. I've worked through a simple wiring setup using my bench top power supply and got a strip test working.

Now that I have the actual fabrication done I want to move the power from my bench top supply to a regular wall adapter supply.

The problem I'm running into is that when I provide power from the wall supply the led strip no longer gets the data from the signal pin.While troubleshooting I connected my multimeter to the signal pin and all of a sudden the strip's first LED got the signals and started lighting up.

I'm assuming I'm running into an impedance issue, but I'm not sure why or how to solve it other than trying different resistor values on the signal pin to overcome the issue.

Here's a rough diagram. there's not a lot to it:

diagram

I couldn't find info on the forward voltage of the strip or a datasheet for it, so I turned all of the LEDs white and looked at the current draw on my bench top supply:

max current draw

So the whole matrix is pulling 1.5 amps.

The trinket M0's GPIO voltage is 3.3v, so if I'm thinking about this right to figure out the resistor I need I would use ohms law:

r = V/I

So in my case:

r = 3.3/1.5 = 2.2ohm

Is that right? While I know some I still feel like a novice and I'm working alone and teaching myself, so I'm not sure if I'm thinking of everything correctly.

I also shot a video showing what's happening if that helps: https://vimeo.com/496062949

UPDATE

And actually to simplify things further, I just tried moving the trinket over to the external power supply as well and I get the same issue.

So even with this diagram:

simplified circuit

Update

A closer look at the all-on-the-wall-adapter circuit:

enter image description here

9
  • The resistor is on a signal line. There should hardly be any current there. I don't thing it's anything to do with that resistor. Have you tried powering the trinket from the same 5V brick, instead of USB? I think it might be a eathing problem. The bench power supply is mains earth referenced, while the brick is probably floating. Are you also really sure the grounds are connected? Maybe there's a loose breadboard connection.
    – Gerben
    Dec 31, 2020 at 17:41
  • 1
    WS2811 expected a minimum of 0.7xVdd for a logic high signal, which is 3.5V. You're marginal at best even if everything is grounded properly. You should level-shift that signal. (And indeed that LED isn't a dropping resistor - your Trinket would have blown up long ago if you tried to feed 1.5A through one of its pins.)
    – Mat
    Dec 31, 2020 at 17:50
  • Yeah I moved everything to the wall adapter and I double checked the ground connection and it's good, but still have the issue. I'm adding a new pic in of the circuit. Dec 31, 2020 at 17:53
  • @Mat how would i do that level shift? Is this a case where I'd need to add a transistor to provide a higher voltage signal (e.g. pull the 3.3 from the trinket's top right pin) and then control the transistor with my signal pin? Ah wait, I forgot it can't be the 3.3v pin b/c we'd need 3.5, so maybe a voltage divider coming off the 5v power? Dec 31, 2020 at 17:56
  • go back to the two power supply setup ... remove the ground connection between the two power supplies ... connect a ground wire directly from the trinket to the LED strip
    – jsotola
    Dec 31, 2020 at 18:19

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.