-1

I use Ubuntu 20.04, and recently have reinstalled Arduino IDE. After that, I can't program Attiny85 or 2313 with an Arduino Uno board.

Earlier, this setup worked fine for -85 chip.

Test 1: upload a blink sketch to Arduino Uno. Works normally. I connect Uno with a USB-A => USB-B wire, upload it, no issues detected. The LED blinks as expected.

Test 2: according to this tutorial, Doesn't work.

UPDATE: The problem was that I missed the step where you upload an "Arduino ISP" sketch to Arduino itself.

My setup:

  • OS: Ubuntu 20.04
  • Arduino IDE 1.8.13
  • Board: real Arduino Uno (made in Italy)
  • port /dev/ttyA.... in group dialout (no problems to write to, because the blink test on Arduino itself works)

I connect the ports the following way:

Uno  Attiny
10   1 (Reset)
11   5 
12   6
13   7
5V   8 (VCC)
GND  4 (GND)

I also add a 10uF capacitor between Uno Reset pin and Uno GND.

Boards files are downloaded from the following url: https://raw.githubusercontent.com/damellis/attiny/ide-1.6.x-boards-manager/package_damellis_attiny_index.json

Parameters in the IDE:

  • Board: "Attiny25/45/85"
  • Processor: Attiny85
  • Programmer: Arduino as ISP

I run Compile, ends successfully.

I run Burn Bootloader, and see the result:

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x18
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x7e
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xfe
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x9e
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x9e
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x60
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x66
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xe6
Error while burning bootloader.

If I try uploading the sketch without the bootloader, it fails same way.

What has changed since the reinstall?

Detailed shell output: https://pastebin.com/iKsGp6yp

Same happens on Chinese noname "Uno" board: the blink sketch works on Arduino itself normally, but not when I try using it as programmer for Attiny.

UPDATE: @timemage asked about reinstalls, and I did do that. After last successful run, I installed arduino package from Ubuntu repo. That package is outdated. I removed it afterwards (apt remove arduino) before reinstalling the official package. It stopped working with Attiny. Now I did apt-get purge arduino, it removed arduino-core and autoremove also removed some packages. Re-installed Arduino IDE from official .tag.gz after that, but the problem still persists.

UPDATE: The problem was that I missed the step where you upload an "Arduino ISP" sketch to Arduino itself. Thanks to Majenko for pointing this.

9
  • 1
    The sequence should be: 1. load programming sketch. 2. compile. 3. upload. 4. install 10uF capacitor. 5. burn bootloader. Are you doing all those steps in that exact order? – Majenko Dec 20 '20 at 11:12
  • Did you repeat the step: "Adding ATtiny85 Support to Arduino IDE" from your tutorial? And did that succeed? – DataFiddler Dec 20 '20 at 11:14
  • Showing the avedude command-line as it was generated by the IDE might help. – timemage Dec 20 '20 at 12:44
  • @DataFiddler yes, without it I wouldn't be able to choose the board/processor from the menu. – culebrón Dec 20 '20 at 12:46
  • 2
    @Majenko I walked again through the tutorial and now I understood what you meant. I missed that I needed a sketch for Arduino itself. That fixed the problem. – culebrón Dec 20 '20 at 17:40
0

I figured out that I missed the first step of the tutorial: upload "Arduino ISP" sketch to Arduino:

To program the ATtiny85 we need to first set Arduino Uno in ISP mode. Connect your Arduino Uno to the PC. Open Arduino IDE and open the ArduinoISP example file (File -> Examples -> ArduinoISP) and upload it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.