2

I just bought an Esp8266(not the node MCU) and tried connecting it with Arduino without a USB to serial converter but in vain. I am a beginner and don't know what to do. It is not responding to AT commands. Can anyone give me a detailed step by step process to connect it?enter image description here

I am using Arduino UNO R3.

This is my connection diagram:-

enter image description here

I uploaded an empty code(Bare minimum example code), just to see if the AT commands are working, but it failed to respond. I reflashed it, then also it is not working. when I type AT it shows nothing. But if I shake it, sometimes it shows gibberish.

5
  • Right now all I'm trying to go is get you to bring it up to the state of being an answerable question. Already looks better than what you started with. Still a ways to go. I'm confused as to what the thinking behind "uploaded an empty code" is. How were you thinking that would help? – timemage Dec 19 '20 at 17:11
  • Does this answer your question? Arduino Uno with ESP8266-01 with AT – Juraj Dec 19 '20 at 17:57
  • 1
    Hey @Juraj I tried to send some commands, it shows gibberish and wdt reset with rst_cause:4 – vasantha raj Dec 19 '20 at 18:11
  • If it shows gibberish when you shake it, you have a bad connection somewhere. Also, what code are you trying this with? Do the baud rates match and did you set them to a low enough value (9600 recommended)? – StarCat Dec 20 '20 at 9:34
  • 1
    Hey, thanks for replying. Just bought another one and it worked properly. – vasantha raj Jan 12 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.