2

I have a DFPlayer Mini bought from AliExpress. The player works correctly in standalone mode, but I am having troubles while using it with the following components:

  • Seeduino v4.0;
  • 2GB Smartbuy MicroSD card.

When I try to use this standard sketch for Arduino to connect my Seeeduino V4 to the player:

  • if I set the serial like mySoftwareSerial(11, 10), the player's tiny LED turns on for 2 seconds, then it switches off, and after that, the board tells me the error message below (video here);
  • if I set the serial like mySoftwareSerial(10, 11), the player`s tiny LED switches on and remains being switched on, while the board tells me the error message below (video here):
DFRobot DFPlayer Mini Demo
Initializing DFPlayer ... (May take 3~5 seconds)
Unable to begin:
1.Please recheck the connection!
2.Please insert the SD card!

This module's image: Image

The circuit diagram:

schematic

simulate this circuit – Schematic created using CircuitLab

I have tried almost everything I could. I changed the filenames on my SD card, tried to use different pins, tried to use different wires..! I even tried to disconnect the speaker from the player!

I also had seen this message on the manufacturer`s forum:

I found that the solder joint on the TX pin was bridged to the SD card holder, effectively bridging the pin to the ground. Try a continuity test between the TX and ground. If they are connected you have a bad joint. I was able to remove the excess solder and it worked fine after that. It's a medium difficulty soldering task.

Maybe, it`s my case?

11
  • 1
    The module functions as a stand-alone player. If you find a tutorial where someone is controlling it with buttons and you have success with that, you can eliminate any concerns you may have about the sdcard, its formatting, the sound files, and their formatting. You can then edit your question to remove those concerns, put the actual code your using, and clear images of the actual wiring.
    – timemage
    Dec 9, 2020 at 14:01
  • You didn't show, how you connected the player to the Arduino
    – chrisl
    Dec 9, 2020 at 14:46
  • 1
    @chrisl, edited the question.
    – Starter
    Dec 10, 2020 at 1:51
  • @timemage, fixed everything I could
    – Starter
    Dec 10, 2020 at 15:45
  • 2
    The player works correctly in standalone mode, @timemage.
    – Starter
    Dec 11, 2020 at 13:44

2 Answers 2

1

Please check if the RX/TX pins are messed up. In my case, simply RX and TX wires' places' switching did help!

1

I simply removed the test for the return value of the constructor and assumed it initialised correctly. It then ran properly every time I started it. I have no explanation for this, but it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.