0

I was trying to reset my Arduino Yun (WLAN button pressed for more than 30 seconds), but it just kept on blinking for about 10 minutes. Then I finally got impatient and restarted the Yun. After the restart, there was no WLAN (blue) or USB (white) LED blinking or glowing anymore. I am unable to connect through the Wifi network, the Yun does not create it's own Wifi network and unfortunately when connected via Ethernet, I can still not navigate to arduino.local or 192.168.240.1.

So I have a feeling that somehow only the AVR is still functioning (because I can still upload sketches) and nothing else.

I have updated the firmware to the latest version (OpenWrt-Yun 1.5.3). Is there a way to connect or reset, if the Ethernet does not work? Can I upload a sketch to check in the console if the Linino interface still functions.

Thanks in advance!

  • I have the same problem. what will be the solution? Please give me in steps. I am in final part of my project and it happened. Pls help me.. – user7224 Feb 9 '15 at 5:45
  • As suggested in the correct answer, try to upload the YunSerialTerminal example and open the Serial Monitor to see what's wrong? And if nothing works, you can try arduino.cc/en/Tutorial/YunUBootReflash tutorial. But it's a bit tricky I suppose. – Ashin Mandal Feb 10 '15 at 13:11
0

Try uploading YunSerialTerminal example, opening the serial monitor and pressing the YUN RST button. You should see the linux side starting.

If it starts but it looks somehow bricked, you could try following the http://arduino.cc/en/Tutorial/YunUBootReflash tutorial.

  • Hello! Thanks! So I was able to upload the YunSerialTerminal example and I did see the linux start up. But it just gets stuck at the following line: [ 32.150000] Kernel panic - not syncing: Attempted to kill init! I think I'll try to go for YunUBootReflash. I am not very sure how I can try to fix boot-up issues with the linux on the Arduino. – Ashin Mandal Jan 13 '15 at 9:41
  • So, it works now! I did not go for a complete re-flash though. I had extended the Yun disk space before - arduino.cc/en/Tutorial/ExpandingYunDiskSpace But just removing the SD card made the linux boot up properly. I just formatted the SD card separately and put it back in. Everything seems to be in order. Thank you again! – Ashin Mandal Jan 13 '15 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.