I'm using a MacBook Pro with 10.13.6, an Official Arduino Uno Board and Arduino 1.8.13 IDE.

I'm having troubles uploading code to the Arduino Board. I have 5 ports available:

  • dev/cu.-AvnetaSPPPort
  • dev/cu.Bluetooth-Incoming-Port
  • dev/cu.SRS-BTX300-DataInteract
  • dev/cu.RS-XB41-BluetoothSeria-1

I'm not sure if any oh these ports is the correct one but I've already tried all of them and I keep getting errors like: "avrdude: ser_open(): can't open device "/dev/cu.-AvneraSPPPort": Resource busy"

Some weeks ago I was trying Arduino on the same computer and all went good but right now I can't get it to work, however I don't remember wich port was selected.

In the IDE the board I have selected is "Arduino Uno" and as Programmer option I have "AVRISP mkll".

Does anyone know how to solve this?

  • @timemage the board is an official UNO Commented Nov 30, 2020 at 18:43
  • @timemage done! Commented Nov 30, 2020 at 18:49
  • From what little I can tell, on a Mac it should show up with usbmodem in the name. For my part unless you want me to "it's not on that list" as an answer, you're going to have to add some extra detail. What exactly I'm not sure. I guess whatever you can say about what if anything appears in the mac device manager and what your usb connection from the mac to the uno usb port looks like.
    – timemage
    Commented Nov 30, 2020 at 18:56
  • which sketch did you load last time it worked? ... that sketch runs when you plug the UNO into a USB port and may be interfering somehow
    – jsotola
    Commented Nov 30, 2020 at 19:42
  • There's not much the sketch can do, short of activating some external circuitry that causes the board to brown out, that will drop an UNO off USB.
    – timemage
    Commented Nov 30, 2020 at 19:59

2 Answers 2


I finally solved the problem.

Although the Board has no information about being a clone (it only says "Uno" and was provided by the faculty so I think it is official), I was looking on the web for similar problems and found out that installing CH340 Driver was working for a lot of users. So that was what I did and now it works like a charm.


List the ports again, with- and without the Arduino plugged in: open the built-in Terminal app (usually in Applications/Utilities) and type 'ls /dev/tty.*'. The difference will tell you the Arduino's device name.

"Resource Busy" generally means something else has already connected to that port. Is a terminal-emulator program running and connected to that port? If you're using a terminal-emulator other than the one built in to the IDE, you have tell it to disconnect before you can upload to the Arduino.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.