1

I've been using an Arduino Leonardo on my Windows machine for a few days now without too much trouble but today the COM port disappeared. I've been able to successfully send sketches to the arduino and execute them so everything was working until recently. When I look in Device manager on the control panel there is no com port listed for the arduino. If I reset the device then a com port shows up briefly with "Arduino Leonardo BootLoader" but after a few seconds that disappears. I've tried USB2.0 and USB 3.0 ports on my PC and a different cable but to no avail. I don't have anything listed under "Other Devices" and I'm out of ideas for what could be the trouble. I'm trying to get it recognised now as just the leonardo with nothing connected to any pin. Any ideas of what to try?

migrated from electronics.stackexchange.com Jan 11 '15 at 19:02

This question came from our site for electronics and electrical engineering professionals, students, and enthusiasts.

1

Strange, it's resolved itself/I resolved it. I don't know whether what I did was actually responsible for solving this but I'm back in business: * I reset the board so that the bootloader appeared as a com port * I set the arduino IDE to use the port that appeared for the bootloader * I uploaded a simple sketch and pressed reset during the "upload phase" so that the port appeared during the upload * the upload completed successfully and the arduino was back in the com port list

I'd still be interested to understand what I did that caused the problem in the first place but I suppose something was corrupted on the board?

  • Probably you had a sketck witch was messing with serial, like you forgot Serial.begin() or the while needed by it, also this reset is needed on the uno when write too much on serial. – Lesto Jan 13 '15 at 7:18
  • You could be right. I have a button press to trigger some actions and I'd been monitoring the button status using a serial write. It could be I was hammering that method call or had messed something up around the serial comms. – Jon Jan 14 '15 at 9:15
0

Do note that on some example sketches the setup of the "Serial." function requires that there is special check for the serial port to be recognized/enabled (for the Leonardo only). Have you actually run a serial sketch to see if the com port comes back?

Did you load any other software or run virus checks that might have interfered with the special USB/Com driver?

You might try unloading and reloading the special driver used with the USB. Be sure to use the one specifically for Win8.

  • My suspicion is that the board is dead - I've tried to install to a Win 7 laptop which also doesn't recognise it except during the bootloader sequence. I can't load any sketch onto the board to test with since the board doesn't showup with a com port. so the IDE doesn't have anything to connect to. – Jon Jan 11 '15 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.