1

While working on a project I tried sending data from my Arduino NANO to ATMega64 placed on AREXX Robot arm PCB via TXD/RXD. After plugging in VCC, GND, TXD and RXD to UART socket it didn't work so I figured the socket itself must be backwords or mirror image from my perspective. Then I tried plugging everything in on the other side of the socket and as I plugged VCC to one of the pins a little smoke came out (I can't specify exact place where smoke came from) and from now on there is no connection to the robot. However LEDs seem to work just like before the 'incident'. It can be seen as COM but, desktop app constantly displays 'Connection failed' when trying to access the robot. It seems that I plugged VCC to the MRESET pin and GND to the RXD1 pin of the ATMega64. Can anyone help define if my processor is burnt? And if so, what can I do to fix the robot? Are there any other ways to send data to ATMega considering it is already programmed adn I want to keep it that way? Unfotunately, replacing ATMega isn't possible for me. Thanks in advance for any help.

UART :

enter image description here

ATMega :

enter image description here

Robot PCB :

enter image description here

  • what does this mean? ... other side of the socket ....... which pin is this? ... I plugged VCC to one of the pins ... what is that pin connected to? – jsotola Nov 23 '20 at 20:04
  • 1
    Yes, it's dead. You will have to learn to solder SMD components and replace the ATMega. – Majenko Nov 23 '20 at 20:05
  • @jsotola just like I wrote, I plugged VCC to MRESET pin and GND to the ATMega's RXD1 pin. – FewArc Nov 23 '20 at 20:15
  • @Majenko Even if LEDs like servo power LED or main power LED are on after turning on the robot? – FewArc Nov 23 '20 at 20:17
  • 2
    Yes. It sounds like you burned out the RX pin of the MCU, which means no communication for you any more. – Majenko Nov 23 '20 at 20:19
3

Smoke is a definite sign something failed. The LED (power indicator)is independent of the microprocessor, it just indicates power is applied in the appropriate direction. Go to the basics, and load the simple blink sketch and see if it works, if so you are lucky. You then might want to write some code to check all the outputs and inputs. It is possible you destroyed both devices, you need to do some investigating to determine what is still properly operating.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.