1
  • I am using a Windows 10 laptop. Behind the nodemcu it says that download CH340G driver.
  • I already had arduino ide and the esp libraries were already installed because i was using a esp8266 01 device before.
  • I bought a Nodemcu i downloaded the driver for it CH340G driver.
  • When i install the driver it says that The drive is successfully pre-installed in advance!
  • When I plug my Nodemcu to my computer with a new cable blue lights come from the board and it stops. And windows doesn't make a sound which indicates that it sees the device.
  • I don't think the nodemcu is the problem. How do i fix this?
  • so are you are not able to see the nodemcu in arduino – xbox gamer Oct 28 '20 at 17:29
  • In arduino IDE i can see the nodemcu in the cards section but when it is plugged in there are no ports attached to the nodemcu. Windows does not see it – BarisUygunn Oct 28 '20 at 17:30
  • so what's the problem if u can see it in Arduino then you can upload code to the node muc please tell me what you want . – xbox gamer Oct 28 '20 at 17:34
  • If Windows doesn't make a sound then it doesn't see the device being plugged in. Are you sure you're usb cable has data wires in it? – Majenko Oct 28 '20 at 17:36
  • does your board have a CH340G chip? – jsotola Oct 28 '20 at 17:40
1

Read through https://stackoverflow.com/questions/43007501/nodemcu-not-detected-by-computer#:~:text=I%20had%20to%20install%20the,Afterwards%2C%20it%20worked.&text=For%20future%20people%20with%20this,and%20it%20wouldn't%20detect. and also search few ways to remove oxidation from pins like using autosol (I have never used it ) . Try uploading code through FTDI modules or just get it replaced.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.