1

Kunal Gupta: Guys plss help me .... I am having issues in using stepper motor

I have tried both 28bjy with uln2003 and l293d .. giving it output supply of 5V . Motor is vibrating but its shaft is not moving. And even if shaft runs then it is different from what is expected by the logic of code

Similarly tried NEMA 17 stepper motor 4.5 KG using drv8825 driver and L293D driver ... Giving 12 v external supply.

And same results as 28bjy .... motor vibrating but its shaft is mot moving as expected or absolutely not moving

I have read and understood all the concept of driving stepper motor by full step method and hafl step method ....and using at first direct examples from net .. but still not figuring out what is the problem

1
  • 3
    Can you please show your code and your wiring? A vibrating stepper motor suggests, that the phases of the motor are not driven in the right order. I already wrote an answer to a question about the 28BYJ-48 stepper and the ULN2003 once. Maybe it helps you: arduino.stackexchange.com/questions/57089/… – chrisl Oct 24 '20 at 20:22
1

Try lowering the rpm in the code. I had a similar issue with anything over about 18rpm using certain libraries with certain stepper motors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.